Ask Your Question

no ports available when associating floating ips for my new instance

asked 2014-03-10 05:16:09 -0600

rubik gravatar image

I am a novice here.

I followed quick start( successfully and I am trying to run an instance as described in this page ( ( ).

I was stuck in step 6 Associate Floating IP. I have set floating IP range and this is what I get when I execute command "nova-manage floating list":

None None nova eth0

None None nova eth0

None None nova eth0

None None nova eth0


None None nova eth0

None None nova eth0

When I open "Manage Floating IP Associations" dialog, IP Address can be selected. But the option "port to be associated" remains "No ports available" then I can not associate successfully.

So what is the problem ?

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted

answered 2014-03-10 10:03:18 -0600

foexle gravatar image

Which version you are running 2013.2.2 ?

If yes check if you have the right Neutron policies: "get_port": "rule:admin_or_owner", "get_port:queue_id": "rule:admin_only", "get_port:binding:vif_type": "rule:admin_only", "get_port:binding:capabilities": "rule:admin_only", "get_port:binding:host_id": "rule:admin_only", "get_port:binding:profile": "rule:admin_only", "get_port:allowed_address_pairs": "rule:admin_or_owner", "get_port:fixed_ips": "rule:admin_or_owner", "get_port:mac_address": "rule:admin_or_owner", "update_port": "rule:admin_or_owner", "update_port:fixed_ips": "rule:admin_or_network_owner",

In addition you should check if you don't have reached your port quota: neutron quota-list

Cheers Heiko

edit flag offensive delete link more


Yes, I am running 2013.2.2-1.el6. I checked my neutron policy file: /etc/neutron/policy.json. I found the following pairs are missing : "get_port:allowed_address_pairs": "rule:admin_or_owner", "get_port:fixed_ips": "rule:admin_or_owner", "get_port:mac_address": "rule:admin_or_owner", Then I added them to policy.json, reboot the server and logged into the dashboard again. But it remained the same situation....

rubik gravatar imagerubik ( 2014-03-11 08:11:44 -0600 )edit

and the output of your quota ?

foexle gravatar imagefoexle ( 2014-03-12 10:56:50 -0600 )edit

I input "neutron quota-list" in demo user, the message says: "User does not have admin privileges.....". Then I source keystonerc_admin and execute "neutron quota-list" again. There is nothing output. I have tried "neutron quota-show" and output the following results: +---------------------+-------+ | Field | Value | +---------------------+-------+ | floatingip | 50 | | network | 10 | | port | 50 | | router | 10 | | security_group | 10 | | security_group_rule | 100 | | subnet | 10 | +---------------------+-------+ B.T.W. I found a strange thing. When I lauch another instance using image cirros which is prebuilt in openstack, I can associate floating ip (, successfully. But the Fedora19 image still can not associate floating ip.

rubik gravatar imagerubik ( 2014-03-14 10:33:32 -0600 )edit

check that

neutron port-list --tenant_id <your tenant_id> --status ACTIVE | wc -l

and substract 4, if you reached 50, you need to update your quota.

foexle gravatar imagefoexle ( 2014-04-10 08:16:21 -0600 )edit

Am bumping into the same problem with 2014.1.1 (icehouse)

In policy.json am missing :
"get_port:allowed_address_pairs": "rule:admin_or_owner", "get_port:fixed_ips": "rule:admin_or_owner", "get_port:mac_address": "rule:admin_or_owner",

Still no ports available.

arthur.lutz gravatar imagearthur.lutz ( 2014-08-26 02:38:12 -0600 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools



Asked: 2014-03-10 05:16:09 -0600

Seen: 3,958 times

Last updated: Mar 10 '14