Ask Your Question
2

stack.sh create_keystone_accounts: Gateway Timeout 504

asked 2014-03-08 11:48:33 -0500

rossi gravatar image

updated 2014-03-18 12:02:46 -0500

smaffulli gravatar image

Trying to install devstack on a VM with ubuntu 12.04, I got the followings errors when creating keystone accounts :

 + create_keystone_accounts
2014-03-08 18:39:56.232 | ++ grep ' id '
2014-03-08 18:39:56.233 | ++ get_field 2
2014-03-08 18:39:56.235 | ++ read data
2014-03-08 18:39:56.236 | ++ openstack project create admin
2014-03-08 18:40:56.128 | ERROR: cliff.app Gateway Timeout (HTTP 504)
2014-03-08 18:40:56.149 | + ADMIN_TENANT=
2014-03-08 18:40:56.150 | ++ openstack user create admin --project '' --email admin@example.com --passwor   d adminPassword
2014-03-08 18:40:56.152 | ++ get_field 2
2014-03-08 18:40:56.153 | ++ read data
2014-03-08 18:40:56.154 | ++ grep ' id '
2014-03-08 18:41:57.152 | ERROR: cliff.app Gateway Timeout (HTTP 504)
2014-03-08 18:41:57.172 | + ADMIN_USER=
2014-03-08 18:41:57.174 | ++ openstack role create admin
2014-03-08 18:41:57.175 | ++ get_field 2
2014-03-08 18:41:57.177 | ++ read data
2014-03-08 18:41:57.178 | ++ grep ' id '
2014-03-08 18:42:57.694 | ERROR: cliff.app Gateway Timeout (HTTP 504)
2014-03-08 18:42:57.714 | + ADMIN_ROLE=
2014-03-08 18:42:57.715 | + openstack role add --project --user
2014-03-08 18:42:58.037 | usage: openstack role add [-h] [-f {shell,table}] [-c COLUMN]
2014-03-08 18:42:58.039 |                           [--variable VARIABLE] [--prefix PREFIX] --project
2014-03-08 18:42:58.040 |                           <project> --user <user>
2014-03-08 18:42:58.041 |                           <role>
2014-03-08 18:42:58.042 | openstack role add: error: argument --project: expected one argument
stack@u12-63555:~/devstack$ 2014-03-08 18:42:58.055 | + exit_trap
2014-03-08 18:42:58.057 | + local r=2
2014-03-08 18:42:58.058 | ++ jobs -p
2014-03-08 18:42:58.059 | + jobs=
2014-03-08 18:42:58.060 | + [[ -n '' ]]
2014-03-08 18:42:58.061 | + exit 2

My HOST_IP in local.conf is set with my eth0 address IP. However I have a complex network config hereunder:

docker0   Link encap:Ethernet  HWaddr a2:9d:df:0b:0e:dd
          inet addr:172.17.42.1  Bcast:0.0.0.0  Mask:255.255.0.0
          inet6 addr: fe80::a09d:dfff:fe0b:edd/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:7002 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:602124 (602.1 KB)

eth0      Link encap:Ethernet  HWaddr 00:50:56:97:27:53
          inet addr:10.200.77.115  Bcast:10.200.79.255  Mask:255.255.240.0
          inet6 addr: fe80::250:56ff:fe97:2753/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:42487116 errors:0 dropped:30962 overruns:0 frame:0
          TX packets:2127952 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:5028887632 (5.0 GB)  TX bytes:360808381 (360.8 MB)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:176328 errors:0 dropped ...
(more)
edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2014-03-10 08:16:55 -0500

rossi gravatar image

updated 2014-03-18 12:02:02 -0500

smaffulli gravatar image

problem resolved by adding

#
# Openstack branches
#
HORIZON_BRANCH=master
KEYSTONE_BRANCH=master
GLANCE_BRANCH=master
CINDER_BRANCH=master
NOVA_BRANCH=master
NEUTRON_BRANCH=master
CEILOMETER_BRANCH=master
HEAT_BRANCH=master
SWIFT_BRANCH=master
REQUIREMENTS_BRANCH=master
GLANCECLIENT_BRANCH=master
KEYSTONECLIENT_BRANCH=master
NOVACLIENT_BRANCH=master
CINDERCLIENT_BRANCH=master
CEILOMETERCLIENT_BRANCH=master
OPENSTACKCLIENT_BRANCH=master

in my local.conf

with also no_proxy=local, localhost, 127.0.0.1, my_eth0_adress in .bashrc

edit flag offensive delete link more

Comments

i am also facing with the same issue but although i fallow the steps you suggested, the still getting the same error.Are there any other steps that must be done?Did you add the "no_proxy" variable @ stack/.bashrc?Thanks.

ferit gravatar imageferit ( 2014-06-25 14:16:08 -0500 )edit

i forgot to put variables between " ", it must be no_proxy="local, localhost, 127.0.0.1, my_eth0_adress".My bad, thanks for your answer.

ferit gravatar imageferit ( 2014-06-27 09:28:02 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-03-08 11:48:33 -0500

Seen: 2,732 times

Last updated: Mar 18 '14