Ask Your Question
2

ML2 driver with GRE not working on multi-node installation

asked 2014-03-06 10:51:39 -0500

updated 2014-03-06 10:52:21 -0500

Hi,

I have a mult-node installation of openstack with Ubuntu 12.04.4 LTS (kernel 3.8.0-32) and I want to configure ML2 plugin in GRE. VM (a simple Cirros) send dhcp request from compute node but network node don't receive any packet. I try to do a tcpdump on br-int interface without view any packet. If I do a tcpdump on "qvof08c873f-04" I see DHCP request.

Thanks.

Salvo

# modinfo openvswitch
filename:       /lib/modules/3.8.0-32-generic/updates/dkms/openvswitch.ko
version:        1.10.2
license:        GPL
description:    Open vSwitch switching datapath
srcversion:     C57BFF12C03B30A057F0B4B
depends:
vermagic:       3.8.0-32-generic SMP mod_unload modversions

ml2_conf.ini on network node

[ml2]
type_drivers = gre
tenant_network_types = gre
mechanism_driver = openvswitch,linuxbridge
[ml2_type_flat]
[ml2_type_vlan]
[ml2_type_gre]
tunnel_id_ranges = 1:1000
[ml2_type_vxlan]
[database]
sql_connection = mysql://neutron:*******@10.170.0.40/neutron
[ovs]
local_ip = 10.170.1.45
enable_tunneling = True
[agent]
tunnel_types = gre
root_helper = sudo /usr/bin/neutron-rootwrap /etc/neutron/rootwrap.conf
[securitygroup]
firewall_driver = neutron.agent.linux.iptables_firewall.OVSHybridIptablesFirewallDriver

ml2_conf.ini on compute node ...the same but with

local_ip = 10.170.1.31

Network Node

# ovs-vsctl show 
f83bdf-20f5-4fa5-9e79-c57d825e3ceb
Bridge br-ex
    Port "eth2"
        Interface "eth2"
    Port br-ex
        Interface br-ex
            type: internal
Bridge br-int
    Port "tap7e693292-09"
        tag: 4095
        Interface "tap7e693292-09"
            type: internal
    Port patch-tun
        Interface patch-tun
            type: patch
            options: {peer=patch-int}
    Port br-int
        Interface br-int
            type: internal
Bridge br-tun
    Port "gre-10.170.1.31"
        Interface "gre-10.170.1.31"
            type: gre
            options: {in_key=flow, local_ip="10.170.1.45", out_key=flow, remote_ip="10.170.1.31"}
    Port patch-int
        Interface patch-int
            type: patch
            options: {peer=patch-tun}
    Port br-tun
        Interface br-tun
            type: internal
ovs_version: "1.10.2"

Compute Node

# ovs-vsctl show 
591e9b9b-a9b7-488f-abb4-2c54d34f36db
    Bridge br-tun
        Port patch-int
            Interface patch-int
                type: patch
                options: {peer=patch-tun}
        Port br-tun
            Interface br-tun
                type: internal
        Port "gre-10.170.1.45"
            Interface "gre-10.170.1.45"
                type: gre
                options: {in_key=flow, local_ip="10.170.1.31", out_key=flow, remote_ip="10.170.1.45"}
    Bridge br-int
        Port br-int
            Interface br-int
                type: internal
        Port patch-tun
            Interface patch-tun
                type: patch
                options: {peer=patch-int}
        Port "qvof08c873f-04"
            tag: 4095
            Interface "qvof08c873f-04"
    ovs_version: "1.10.2"
edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2014-03-10 12:09:57 -0500

updated 2014-03-10 12:10:30 -0500

I know the solution. I have done a mistake when i have written the mechanism_drivers parameter in the ml2_conf.ini file. I forgotten the character s at the end of the word

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Get to know Ask OpenStack

Resources for moderators

Question Tools

Follow
1 follower

Stats

Asked: 2014-03-06 10:51:39 -0500

Seen: 742 times

Last updated: Mar 10 '14