Ask Your Question
3

neutron not schedule the network to DHCP agent

asked 2014-03-05 23:34:13 -0500

chen-li gravatar image

Hi list,

I’m working on CentOS 6.4 + Havana.

When I create a new network, I get error message in /var/log/neutron/server.log:

Run command:

  neutron net-create test-network03

Output in /var/log/neutron/server.log:

  2014-03-06 13:28:37.078 21277 ERROR neutron.api.rpc.agentnotifiers.dhcp_rpc_agent_api [-] No DHCP agents are associated with network 'b02112bf-9fe5-4053-8ced-e08bd2547b49'. Unable to send notification for 'network_create_end' with payload: {'network': {'status': 'ACTIVE', 'subnets': [], 'name': u'test-network03', 'provider:physical_network': None, 'admin_state_up': True, 'tenant_id': u'1e57be810f854bcdb73901567140ac48', 'provider:network_type': u'gre', 'shared': False, 'id': 'b02112bf-9fe5-4053-8ced-e08bd2547b49', 'provider:segmentation_id': 3L}}

Run command:

  neutron subnet-create test-network03 90.1.130.0/24

Output in /var/log/neutron/server.log:

  2014-03-06 13:30:43.414 21277 INFO urllib3.connectionpool [-] Starting new HTTP connection (1): host-keystone
  2014-03-06 13:30:43.516 21277 ERROR neutron.api.rpc.agentnotifiers.dhcp_rpc_agent_api [-] No DHCP agents are associated with network 'b02112bf-9fe5-4053-8ced-e08bd2547b49'. Unable to send notification for 'subnet_create_end' with payload: {'subnet': {'name': '', 'enable_dhcp': True, 'network_id': u'b02112bf-9fe5-4053-8ced-e08bd2547b49', 'tenant_id': u'1e57be810f854bcdb73901567140ac48', 'dns_nameservers': [], 'allocation_pools': [{'start': '90.1.130.2', 'end': '90.1.130.254'}], 'host_routes': [], 'ip_version': 4, 'gateway_ip': '90.1.130.1', 'cidr': u'90.1.130.0/24', 'id': '25d1653f-d043-41e6-9206-d020cab041b1'}}

I do have an active DHCP agent:

  neutron agent-list
  +--------------------------------------+--------------------+-------------+-------+----------------+
  | id                                   | agent_type         | host        | alive | admin_state_up |
  +--------------------------------------+--------------------+-------------+-------+----------------+
  | 246dd973-ebfd-4948-b655-6171f5866b19 | DHCP agent         | b-compute05 | :-)   | True           |
  | 5c6260cf-15c2-4757-9170-68be2d5e5d8b | Open vSwitch agent | b-compute05 | :-)   | True           |
  +--------------------------------------+--------------------+-------------+-------+----------------+

Anyone know why this happen ?????

Thanks.

-chen

edit retag flag offensive close merge delete

Comments

could you check in your neutron.conf (not need but should if possible the same on all hosts) dhcp_agent_notification = True dhcp_agents_per_network = 2 (or 1) In addition your agent-list is very short, so i'm missing: * L3-Agent and you are using only one host for vms and network ? Cheers Heiko (sry for this really bad farmatted text it's not working)

foexle gravatar imagefoexle ( 2014-03-07 08:55:20 -0500 )edit

I didn’t change the default configuration, so: # dhcp_agent_notification = True # dhcp_agents_per_network = 1 Yes, I’m just testing a fresh new installation, I haven’t install L3 yet.

chen-li gravatar imagechen-li ( 2014-03-10 20:26:29 -0500 )edit

1 answer

Sort by » oldest newest most voted
0

answered 2014-03-07 09:18:07 -0500

darragh-oreilly gravatar image

updated 2014-03-19 07:44:11 -0500

There is a bug and review in progress for this here.

I believe it is by design that the network is not scheduled automatically to a dhcp agent until the first port is created on it (typically when nova creates a port on it). This gives operators a chance to schedule it manually using neutron dhcp-agent-network-add .... So I think the messages above on network_create_end and subnet_create_end are expected, but they should not really be errors as the bug says.

edit flag offensive delete link more

Comments

No, my network is actually not been scheduled. This is an issue for me !

chen-li gravatar imagechen-li ( 2014-03-10 20:27:18 -0500 )edit

Sorry for my ignorance. I have the same problem descripted in this question and this bugs. Would like to know if it is solved?

rg3 gravatar imagerg3 ( 2014-03-19 07:26:02 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2014-03-05 23:34:13 -0500

Seen: 2,407 times

Last updated: Mar 19 '14