Ask Your Question
0

issue when I using pki as the token provider [closed]

asked 2014-03-05 20:10:58 -0500

chen-li gravatar image

Hi, I'm working under CentOS + Havana.

When I start keystone, I get error in both keystone.log and keystone-startup.log:

    2014-03-06 09:38:18.214 20199 INFO keystone.common.environment [-] Environment configured as: eventlet
    2014-03-06 09:38:18.413 20199 CRITICAL keystone [-] Class pki cannot be found (['Traceback (most recent call last):\n', ' File "/usr/lib/python2.6/site-packages/keystone/openstack/common/importutils.py", line 31, in import_class\n return getattr(sys.modules[mod_str], class_str)\n', "AttributeError: 'module' object has no attribute 'pki'\n"])

Anyone know why this happens???

Thanks.

-chen

My /etc/keystone/keystone.conf is :

  [DEFAULT]
  [sql]
  connection = mysql://keystone:keystone@host-db/keystone
  [identity]
  [credential]
  [trust]
  [os_inherit]
  [catalog]
  driver = keystone.catalog.backends.sql.Catalog
  [endpoint_filter]
  [token]
  driver = keystone.token.backends.memcache.Token
  provider = keystone.token.providers.pki
  [cache]
  [policy]
  [ec2]
  [assignment]
  [oauth1]
  [ssl]
  [signing]
  [ldap]
  [auth]
  methods = external,password,token,oauth1
  password = keystone.auth.plugins.password.Password
  token = keystone.auth.plugins.token.Token
  oauth1 = keystone.auth.plugins.oauth1.OAuth
  [paste_deploy]
edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by chen-li
close date 2014-03-06 22:59:59.333578

1 answer

Sort by ยป oldest newest most voted
2

answered 2014-03-05 23:05:11 -0500

updated 2014-03-05 23:53:01 -0500

Your configuration for PKI provider is wrong

In the default config file you can see

# Controls the token construction, validation, and revocation operations.
# Core providers are keystone.token.providers.[pki|uuid].Provider
# provider =

So if you want to confiure pki provider then your configuration should be

provider = keystone.token.providers.pki.Provider

You are missing Provider suffix in your configuration

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-03-05 20:10:58 -0500

Seen: 225 times

Last updated: Mar 05 '14