Reverting OpenStack snapshots breaks installation

asked 2014-03-04 06:39:13 -0600

c0nsaw gravatar image

updated 2014-03-04 06:40:40 -0600

Hi folks. Im learing the openstack ropes currently. Im using VMware Workstation 10. I have successfully deployed Openstack and configured it for external networking. All good. I have created snaphots along the way in the hope I can simply revert to fully working state as I go along and break stuff.

Particularity I have been snap-shotting as I try to configure my installation to deploy docker containers. I had a working docker, but when I tried to push a container to glance something didn't work, when I went back to last snapshot I found I was unable to get back into horizon, after a lot of googling I got back in by service openstack-ceilometer-api start but was greeted by a load of errors. I rebooted and now I cant spin up any test vm's I had stored. Compute seemed to be reporting itself down.

I will start from scratch again, but is there a safe way to take and revert to snapshots with out breaking my whole installation, as a packstack install takes me about 90 minutes to run each time to get started again

Thanks

edit retag flag offensive close merge delete

Comments

You said that you can't "spin up any test vm's I had stored". How exactly are you trying to launch them? What sort of errors do you see in the nova compute log? What about scheduler/api logs on the controller?

larsks ( 2014-03-07 08:03:51 -0600 )edit

Hi larsks, Ive since blitzed that vm, Im sorry Ive no errors from the logs, being a rookie Im not sure what Im at, Ill try replicate where I was at and report back. I was able launch cirros, fedora and ubuntu vm's, I was able assign them floating ip's, and I could ping and ssh into them from host machine. But after reverting to a vmware created snapshot, I couldn't do any of that, the vm spawn would crap out instantly. thanks for getting back to me !

c0nsaw ( 2014-03-07 14:31:33 -0600 )edit