Ask Your Question
0

Error "CRITICAL ironic [-] __init__() got an unexpected keyword argument 'readonly' ir-api failed to start"

asked 2014-03-04 05:51:16 -0600

manishanker gravatar image

I am trying to install devstack with Ironic but getting following error "Ir-api did not start"

In the logs I have got following description : test@openstackvm7:/opt/stack/tempest$ cd /opt/stack/ironic; /usr/local/bin/ironic-api --config-file=/etc/ironic/ironic.conf || echo "ir-api failed to start" | tee "/opt/stack/status/stack/ir-api.failure" 2014-03-04 21:25:27.006 24411 DEBUG ironic.common.utils [-] Reloading cached file /etc/ironic/policy.json read_cached_file /opt/stack/ironic/ironic/common/utils.py:310 2014-03-04 21:25:27.019 24411 CRITICAL ironic [-] __init__() got an unexpected keyword argument 'readonly' ir-api failed to start test@openstackvm7:/opt/stack/ironic$ cd /opt/stack/ironic; /usr/local/bin/ironic-api --config-file=/etc/ironic/ironic.conf || echo "ir-api failed to start" | tee "/opt/stack/status/stack/ir-api.failure" 2014-03-04 21:38:17.980 24675 DEBUG ironic.common.utils [-] Reloading cached file /etc/ironic/policy.json read_cached_file /opt/stack/ironic/ironic/common/utils.py:310 2014-03-04 21:38:17.991 24675 CRITICAL ironic [-] __init__() got an unexpected keyword argument 'readonly' ir-api failed to start test@openstackvm7:/opt/stack/ironic$ cd /opt/stack/ironic; /usr/local/bin/ironic-api --config-file=/etc/ironic/ironic.conf || echo "ir-api failed to start" | tee "/opt/stack/status/stack/ir-api.failure" 2014-03-04 22:19:28.051 24711 DEBUG ironic.common.utils [-] Reloading cached file /etc/ironic/policy.json read_cached_file /opt/stack/ironic/ironic/common/utils.py:310 2014-03-04 22:19:28.062 24711 CRITICAL ironic [-] __init__() got an unexpected keyword argument 'readonly' ir-api failed to start

edit retag flag offensive close merge delete

Comments

ConnectionError: HTTPConnectionPool(host='172.16.17.8', port=8774): Max retries exceeded with url: /v2/a32d7364e3b645389ae8206ac5d85942/os-simple-tenant-usage?start=2014-03-04T00:00:00&end=2014-03-04T23:59:59&detailed=1 (Caused by <class 'socket.error'="">: [Errno 111] Connection refused) This is the error in the horizon screen .

manishanker gravatar imagemanishanker ( 2014-03-04 05:56:54 -0600 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2014-03-05 01:02:26 -0600

manishanker gravatar image

Solved : For ir-api to work the WSME version should be >= 0.6.During Devstack with ironic installation ,WSME version was 0.5b5. Here is what i have done: 1.#To check the version of WSME sudo pip freeze | grep WSME Output : WSME 0.5b5 2. #Upgrade WSME version sudo pip install -U 'WSME==0.6' 3.#Recheck the WSME version 4.Run the last command in ir-api screen 5.ir-api is up and running.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-03-04 05:51:16 -0600

Seen: 482 times

Last updated: Mar 05 '14