Ask Your Question
1

metadata error running openvswitch agent in neutron

asked 2014-03-03 23:42:26 -0600

RHK gravatar image

updated 2014-03-06 17:26:58 -0600

smaffulli gravatar image

Hello,

I launch a VM Instance with Havana multinode Setup. After launching Vm Instance in logs i am getting Metadata error and i am not able to ping/ssh to Vm Instance from my Controller Node. I check the Logs in Network node and compute node and i found below errors in openvswitchagent.log & dhcpagent.log.

In Network Node:

 root@network:/var/log/neutron# tail -f openvswitch-agent.log

2014-03-04 09:44:53.934 10971 ERROR neutron.openstack.common.rpc.amqp [-] Exception during message handling
2014-03-04 09:44:53.934 10971 TRACE neutron.openstack.common.rpc.amqp Traceback (most recent call last):
2014-03-04 09:44:53.934 10971 TRACE neutron.openstack.common.rpc.amqp   File "/usr/lib/python2.7/dist-packages/neutron/openstack/common/rpc/amqp.py", line 438, in _process_data
2014-03-04 09:44:53.934 10971 TRACE neutron.openstack.common.rpc.amqp     **args)
2014-03-04 09:44:53.934 10971 TRACE neutron.openstack.common.rpc.amqp   File "/usr/lib/python2.7/dist-packages/neutron/openstack/common/rpc/dispatcher.py", line 172, in dispatch
2014-03-04 09:44:53.934 10971 TRACE neutron.openstack.common.rpc.amqp     result = getattr(proxyobj, method)(ctxt, **kwargs)
2014-03-04 09:44:53.934 10971 TRACE neutron.openstack.common.rpc.amqp   File "/usr/lib/python2.7/dist-packages/neutron/plugins/openvswitch/agent/ovs_neutron_agent.py", line 290, in port_update
2014-03-04 09:44:53.934 10971 TRACE neutron.openstack.common.rpc.amqp     self.sg_agent.refresh_firewall()
2014-03-04 09:44:53.934 10971 TRACE neutron.openstack.common.rpc.amqp AttributeError: 'NoneType' object has no attribute 'refresh_firewall'

root@network:/var/log/neutron# tail -f dhcp-agent.log

2014-03-04 09:16:44.587 1646 TRACE neutron.openstack.common.rpc.common   File "/usr/lib/python2.7/dist-packages/amqp/abstract_channel.py", line 69, in wait
2014-03-04 09:16:44.587 1646 TRACE neutron.openstack.common.rpc.common     self.channel_id, allowed_methods)
2014-03-04 09:16:44.587 1646 TRACE neutron.openstack.common.rpc.common   File "/usr/lib/python2.7/dist-packages/amqp/connection.py", line 204, in _wait_method
2014-03-04 09:16:44.587 1646 TRACE neutron.openstack.common.rpc.common     self.method_reader.read_method()
2014-03-04 09:16:44.587 1646 TRACE neutron.openstack.common.rpc.common   File "/usr/lib/python2.7/dist-packages/amqp/method_framing.py", line 187, in read_method
2014-03-04 09:16:44.587 1646 TRACE neutron.openstack.common.rpc.common     raise m
2014-03-04 09:16:44.587 1646 TRACE neutron.openstack.common.rpc.common IOError: Socket closed
2014-03-04 09:16:44.587 1646 TRACE neutron.openstack.common.rpc.common 
2014-03-04 09:21:12.899 5948 ERROR neutron.common.legacy [-] Skipping unknown group key: firewall_driver
2014-03-04 09:44:51.341 10941 ERROR neutron.common.legacy [-] Skipping unknown group key: firewall_driver

In Compute Node:

 root@compute:/var/log/neutron# tail -f openvswitch-agent.log

2014-03-04 09:45:48.228 7614 ERROR neutron.agent.linux.ovs_lib [-] Unable to execute ['ovs-vsctl', '--timeout=2', 'list-ports', 'br-int']. Exception: 
Command: ['sudo', '/usr/bin/neutron-rootwrap', '/etc/neutron/rootwrap.conf', 'ovs-vsctl', '--timeout=2', 'list-ports', 'br-int']
Exit code: 1
Stdout: ''
Stderr: '2014-03-04T04:15:48Z|00001|reconnect|WARN|unix:/var/run/openvswitch/db.sock: connection attempt ...
(more)
edit retag flag offensive close merge delete

Comments

Can you please include your configs?

SamYaple gravatar imageSamYaple ( 2014-03-04 11:51:05 -0600 )edit

1 answer

Sort by ยป oldest newest most voted
1

answered 2014-03-07 04:13:56 -0600

foexle gravatar image

Hi RHK, it seems you'r ovs is not working correctly. I've this problem before, you should check if you have the newest kernel and run again your dkms. dpkg-reconfigure openvswitch-datapath-dkms

for your actual kernel after that restart your system to load the kernel drivers. Your ovs-agent cant connect to your openvswitchd sou your virtual switch isn't running corretly.

Cheers Heiko

edit flag offensive delete link more

Comments

yes its problem with OVS. I reinstalled OVS its working fine now. Thank You.

RHK gravatar imageRHK ( 2014-03-13 05:17:12 -0600 )edit

To reinstall you removed neutron-plugin-openvswitch-agent and reinstalled it? I did that but still facing the same problem.

fresher gravatar imagefresher ( 2014-12-16 23:39:02 -0600 )edit

Hi fresher,

no just reinstall/re-configure the ovs kernel modul. Please read my post above.

foexle gravatar imagefoexle ( 2014-12-31 02:51:13 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2014-03-03 23:42:26 -0600

Seen: 1,318 times

Last updated: Mar 07 '14