Ask Your Question
0

Unable to communicate with identity service

asked 2014-03-03 02:37:23 -0500

t-yamazaki gravatar image

Hello,

I have a problem with keystone (havana). After installation, I got a message as follows:

tyamazaki@tyamazaki:~$ keystone tenant-list WARNING: Bypassing authentication using a token & endpoint (authentication credentials are being ignored). Unable to communicate with identity service: <html><head> <title>404 Not Found</title> </head><body>

Not Found

The requested URL /v2.0/tenants was not found on this server.


Apache/2.4.6 (Ubuntu) Server at 127.0.0.1 Port 35357
</body></html> . (HTTP 404)

Best Regards,

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2014-03-03 23:03:57 -0500

First make sure keystone is running. In the node where keystone is running do 1) netstat -anp | grep -i 35357 --> Should list keystone port 35357 i 2) curl http://localhost:35357 --> This should list version information.

Looks like you running under Apache? Is that correct? If so can you paste your mod-wsgi config file from . /etc/apache2/sites-enabled/

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-03-03 02:37:23 -0500

Seen: 46 times

Last updated: Mar 03 '14