Ask Your Question
0

problem with neutron flat networking with gre tunneling and ovs [closed]

asked 2014-03-02 15:27:58 -0500

ssosothi gravatar image

updated 2014-03-04 00:25:53 -0500

Hello,

I've been trying to setup a 2+ node flat Openstack deployment and I've been having problems getting the VM to network though neutron.

I've used the following guides:

  • http://docs.openstack.org/havana/install-guide/install/apt/content/ch_neutron.html (http://docs.openstack.org/havana/inst...)
  • http://developer.rackspace.com/blog/neutron-networking-simple-flat-network.html (http://developer.rackspace.com/blog/n...)

And I've divided this question into 4 sections,

  • The problem
  • The setup
  • The diagnostics step I've tried
  • Log and Config files

Problem

When I launch a new Cirros instance from horizon, http://paste.openstack.org/show/71159/ (nova show) displays the ip of 128.237.157.251. However the instance cannot dhcp successfully. http://paste.openstack.org/show/71160/ (nova console-log) result.

Setup

My setup currently consists of two nodes

  • The controller&network node: http://nitrogen.club.cc.cmu.edu 128.237.157.43
  • Compute Node: http://gold.club.cc.cmu.edu 128.237.157.43

The machines are running Ubuntu 12.04.4 LTS (GNU/Linux 3.8.0-35-generic x86_64). And every package is latest as of time of this question (I ran apt-get update & upgrade).

My network segment is 128.237.157.0/24 and my gateway is 128.237.157.1 and it will perform dhcp for everything in the segment (this is something I'll like to fix later).

VNC is working correctly on horizon.

Network diagram:

http://i.imgur.com/oa71FIH.png (network diagram)

  • The Controller is connected to the switch via eth0 and has the ovs bridge of br-eth0
  • The Compute Node is connected to the switch via eth1 and has the ovs bridge of br-eth0
  • Each node has br-int and br-tun, the ovs-vsctl show result is in the config section.

Diagnostics

On both, nitrogen (Controller) and gold (Compute), host, upon a reboot I see the following in /var/log/neutron/openvswitch-agent.log:

2014-03-01 18:20:26.130 1024 ERROR neutron.agent.linux.ovs_lib [-] Unable to execute ['ovs-ofctl', 'add-flow', 'br-tun', 'hard_timeout=0,idle_timeout=0,priority=1,in_port=-1,actions=resubmit(,2)']. Exception: 
Command: ['sudo', '/usr/bin/neutron-rootwrap', '/etc/neutron/rootwrap.conf', 'ovs-ofctl', 'add-flow', 'br-tun', 'hard_timeout=0,idle_timeout=0,priority=1,in_port=-1,actions=resubmit(,2)']
Exit code: 1
Stdout: ''
Stderr: 'ovs-ofctl: -1: negative values not supported for in_port\n'

I've taken a look at this question https://ask.openstack.org/en/question/6598/gre-tunnels-not-being-created/ (6598) and ran sudo apt-get install openvswitch-datapath-dkms and rebooted and here's the output from the commands:

modinfo openvswitch

filename:       /lib/modules/3.8.0-35-generic/updates/dkms/openvswitch.ko
version:        1.10.2
license:        GPL
description:    Open vSwitch switching datapath
srcversion:     C57BFF12C03B30A057F0B4B
depends:        
vermagic:       3.8.0-35-generic SMP mod_unload modversions

I think 1.10.2 is the correct version as I ran on the Controller:

  • http://paste.openstack.org/show/71187/ (sudo ovs-vsctl show)
  • http://paste.openstack.org/show/71188/ (sudo ovs-ofctl show br-tun)
  • http://paste.openstack.org/show/71189/ (sudo ovs-vsctl list Interface gre-1)

I still see that ofport is -1 and am now ... (more)

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by dheeru
close date 2014-03-04 11:35:49.117773

Comments

1

You have to getrid of this error. Due to this issue, there will not be any connectivity between the br-int and br-tun. I suggest the following. 1. What is the output of 'ip netns | grep dhcp' 2. Reboot your network node once. Sometimes even thought you have installed the right openvswitch version, it is not loaded properly in kernel. Try doing this. If does not work, will get into next round of troubleshooting.

dheeru gravatar imagedheeru ( 2014-03-02 23:12:46 -0500 )edit

Thank you for your instructions. The result of `ip netns | grep dhcp` is qdhcp-e3da5740-7896-4f50-829a-9fc5bc02b05c. I have rebooted the combined controller&network node but `ovs-vsctl list Interface gre-1` stills output ofport : -1 and log is still being generated.

ssosothi gravatar imagessosothi ( 2014-03-03 20:33:23 -0500 )edit
1

ok. Atleast DHCP is created. You must be running older version of openvswitch. Please run the following and reboot your box. apt-get install openvswitch-datapath-dkms /usr/share/openvswitch/scripts/ovs-ctl force-reload-kmod

dheeru gravatar imagedheeru ( 2014-03-03 22:40:24 -0500 )edit

Thank you for your help, I've followed your instructions and here are the outputs: http://paste.openstack.org/show/72043/. If it will be more convenient for you, I can chat over freenode.

ssosothi gravatar imagessosothi ( 2014-03-04 00:24:14 -0500 )edit
1

I saw the output. I still see the issue with port : "gre-1" ofport : -1. I'm in IST. Shall we chat on gmail today at 9-00 PM IST ? dheerendra.madhusudhana@gmail.com. Confirm the same.

dheeru gravatar imagedheeru ( 2014-03-04 00:56:18 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2014-03-04 11:32:33 -0500

dheeru gravatar image
Had 2 hours of chat session. Here are the observation. After correcting this, port is correct and it is not able to add the flow to br-tun.

Following are not required for GRE
#network_vlan_ranges = ph-eth0:1:1
#bridge_mappings = ph-eth0:br-eth0

Following was missing
[agent]
tunnel_types = gre

also local_ip was mentioned with DNS name. It was expecting real IP address.

After correcting all these, it is creating flow correctly
edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-03-02 15:27:58 -0500

Seen: 1,960 times

Last updated: Mar 04 '14