Ask Your Question
0

Error uploading image: (SSLError): [Errno 1] _ssl.c:499: error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown protocol

asked 2011-10-26 15:45:51 -0500

tonytkdk gravatar image

keystone working for both glance and swift ... Swift 1.4.4 is working well

but when I try to make glance backend stored by swift ... there's the error

============================================ root@glance:~# glance -v add name="testing" is_public=true < glance.sqlite Failed to add image. Got error: Data supplied was not valid. Details: 400 Bad Request

The server could not comply with the request since it is either malformed or otherwise incorrect.

Error uploading image: (SSLError): [Errno 1] _ssl.c:499: error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown protocol Note: Your image metadata may still be in the registry, but the image's status will likely be 'killed'.

Completed in 31.4045 sec.

glance-api.conf http://pastebin.com/FBmcGDHJ

glance-registry.conf http://pastebin.com/DsVJteB4

===========================================

Our swift runs on a normal http port 8888 And auth by keystone , also glance auth by keystone , When I upload image which store in glance local FS , it works . Swift working well when uploading / listing objects for us. But when I integrate them , this error occurred ....

Does glance must using https protocol to communicate with swift ?

edit retag flag offensive close merge delete

9 answers

Sort by ยป oldest newest most voted
1

answered 2011-10-26 18:23:46 -0500

jaypipes gravatar image

Hey again,

http://glance.openstack.org/configuri...

Looks like it does NOT mention the HTTPS default. I'll add a bug about that.

Thanks! -jay

edit flag offensive delete link more
1

answered 2011-10-26 16:54:11 -0500

jaypipes gravatar image

Hi!

In your glance-api.conf, change this:

swift_store_auth_address = 10.103.0.81:5000/v1.0/

to this:

swift_store_auth_address = http://10.103.0.81:5000/v1.0/

Default is HTTPS for Swift, so need to manually set to HTTP.

Cheers, -jay

edit flag offensive delete link more
0

answered 2012-04-11 06:42:01 -0500

zhonghuabaima0913 gravatar image

dear , you should write the value of disk_format and container_format ,

hope to help you .

edit flag offensive delete link more
0

answered 2012-04-11 04:22:46 -0500

I got the same error:

root@pyw:~# glance -v add name="ubuntu" is_public=true<./ubuntu.tar.gz Uploading image 'ubuntu' ===========================================[100%] 116.179371M/s, ETA 0h 0m 0s Failed to add image. Got error: Data supplied was not valid. Details: 400 Bad Request

The server could not comply with the request since it is either malformed or otherwise incorrect.

Failed to activate image. Got error: Data supplied was not valid. Details: 400 Bad Request The server could not comply with the request since it is either malformed or otherwise incorrect. Failed to update image metadata. Got error: Data supplied was not valid. Details: Invalid disk format 'None' for image.
Note: Your image metadata may still be in the registry, but the image's status will likely be 'killed'. Completed in 2.1649 sec.

edit flag offensive delete link more
0

answered 2012-04-02 15:22:18 -0500

jaypipes gravatar image

antiError, please also open a new Question. This one was marked closed quite some time ago.

Best, -jay

edit flag offensive delete link more
0

answered 2012-04-02 15:21:47 -0500

jaypipes gravatar image

anitError, could you provide specifics of the error you are getting please? Thanks, -jay

edit flag offensive delete link more
0

answered 2012-04-01 03:40:43 -0500

zhonghuabaima0913 gravatar image

Does anyone resolve this question??? I didn't use swift.

edit flag offensive delete link more
0

answered 2011-10-26 17:54:13 -0500

tonytkdk gravatar image

As I thought before, thanks for your confirm! I'll have a try tmr, does any doc note this usage currently? Or I can note it into openstack-manuals.

Hugo Kuo

edit flag offensive delete link more
0

answered 2012-04-11 07:20:06 -0500

tonytkdk gravatar image

Example as follow :

glance -v add name="ubuntu" is_public=true disk_format=raw container_format=bare <./ubuntu.tar.gz Uploading image

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2011-10-26 15:45:51 -0500

Seen: 841 times

Last updated: Apr 11 '12