Ask Your Question
0

Savanna-cluster in waiting state

asked 2013-08-31 17:40:31 -0600

sarita18narwal gravatar image

After launch cluster my cluster remains in waiting state giving error time to time .

Error is as follows as:

[31/Aug/2013 23:01:30] "GET /v1.0/0e07c2640ad843c6bd8bc651f1f90873/clusters/8cb3f13b-6322-4ead-8a51-d6aa89f4e55a HTTP/1.1" 200 1783 0.012812 Traceback (most recent call last): File "/root/savanna-venv3/local/lib/python2.7/site-packages/eventlet/greenpool.py", line 80, in _spawn_n_impl func(args, *kwargs) File "/root/savanna-venv3/local/lib/python2.7/site-packages/eventlet/wsgi.py", line 584, in process_request proto.__init__(socket, address, self) File "/usr/lib/python2.7/SocketServer.py", line 638, in __init__ self.handle() File "/usr/lib/python2.7/BaseHTTPServer.py", line 342, in handle self.handle_one_request() File "/root/savanna-venv3/local/lib/python2.7/site-packages/eventlet/wsgi.py", line 226, in handle_one_request self.raw_requestline = self.rfile.readline(self.server.url_length_limit) File "/usr/lib/python2.7/socket.py", line 476, in readline data = self._sock.recv(self._rbufsize) File "/root/savanna-venv3/local/lib/python2.7/site-packages/eventlet/greenio.py", line 262, in recv timeout_exc=socket.timeout("timed out")) File "/root/savanna-venv3/local/lib/python2.7/site-packages/eventlet/hubs/__init__.py", line 151, in trampoline listener = hub.add(hub.READ, fileno, current.switch) File "/root/savanna-venv3/local/lib/python2.7/site-packages/eventlet/hubs/epolls.py", line 48, in add listener = BaseHub.add(self, evtype, fileno, cb) File "/root/savanna-venv3/local/lib/python2.7/site-packages/eventlet/hubs/hub.py", line 126, in add evtype, fileno, evtype)) RuntimeError: Second simultaneous read on fileno 6 detected. Unless you really know what you're doing, make sure that only one greenthread can read any particular socket. Consider using a pools.Pool. If you do know what you're doing and want to disable this error, call eventlet.debug.hub_prevent_multiple_readers(False) (3051) accepted ('10.208.36.26', 47343) 10.208.36.26 - - [31/Aug/2013 23:01:33] "GET /v1.0/0e07c2640ad843c6bd8bc651f1f90873/clusters/8cb3f13b-6322-4ead-8a51-d6aa89f4e55a HTTP/1.1" 200 1783 0.011030

How to overcome this problem ?

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2013-09-01 09:51:05 -0600

dmitrymex gravatar image

The issues is caused by https://bugs.launchpad.net/savanna/+bug/1212341 (https://bugs.launchpad.net/savanna/+b...)

For now I can advise apply the following patch: http://paste.openstack.org/show/45601/

That will not heal the problem completely, but should decrease chance of hitting the issue

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-08-31 17:40:31 -0600

Seen: 90 times

Last updated: Sep 01 '13