Ask Your Question
0

Unexpected error: local variable 'fip' referenced before assignment

asked 2012-03-10 16:15:58 -0500

I want to launch an instance,but when I try to allocate ip I had this error: Unexpected error: local variable 'fip' referenced before assignment do you help me ? thanks

edit retag flag offensive close merge delete

9 answers

Sort by ยป oldest newest most voted
0

answered 2012-07-05 11:02:25 -0500

koolhead17 gravatar image

@Khawla This seems the machine through which your trying to connect is not in same IP range. This you assign floating IP to your running instance before trying to connect?

edit flag offensive delete link more
0

answered 2012-03-13 07:43:54 -0500

Hello,

which Dashboard version do you use? The specified problem is fixed and will be available in the next release - Essex. For now - if you get the latest code from master branch in git - this will solve the problem too.

edit flag offensive delete link more
0

answered 2012-03-15 09:19:03 -0500

Hello, I use Horizon version and my problem is that my instance can't persist when I reboot or terminate it or logging in again I don't found it,every time I logged in I should launch a new instance. any help ? thanks Tihomir,

edit flag offensive delete link more
0

answered 2012-05-10 06:44:18 -0500

The problem with persistence is a configuration issue with Libvirt. You'd look at the libvirt config how to start instances upon restart. Also, it is strange that after logoff-logon the instance is lost... You might be running libvirt in your user session, which for me sounds pretty strange. About termination of instance - that means that the instance is destroyed. It cannot be persisted after termination...

edit flag offensive delete link more
0

answered 2012-05-10 08:56:07 -0500

Thanks Tihomir for response,this problem has solved, but I have a new one, I can create insatnce but I can't ssh it I try to install openstack diablo on ubuntu 11.10 virtual machine ,I use virtualbox, and I have 512 of RAM and 20Go of hard disk so that, is my new problem related with hardware configuration or what? thanks in advance

edit flag offensive delete link more
0

answered 2012-05-10 11:37:44 -0500

Have you created firewall rules on the instance to allow incoming traffic on port 22 ?

Besides that - is there a strong reason that you use diablo but not essex? Essex is a lot more stable and full of new handy features.

edit flag offensive delete link more
0

answered 2012-05-10 11:58:33 -0500

Thanks again for response, yes port 22 is allowed, I can ssh in localhost, then is it possible to install openstack with this hardware configuration (virtual machine , ram and hard disk)? if not what is the configuration needed because I will try to install openstack essex I hope that will be ok. Thanks a lot

edit flag offensive delete link more
0

answered 2012-05-10 14:12:54 -0500

Okay, then we have two things here.

  1. What do you mean with "port 22 is allowed, I can ssh in localhost" ? To ssh the instance - you should use ssh user@10.0.0.1 or whatever the IP of the instance is,

  2. Which image do you use for creating an instance? As I see, using the devstack cirros images, port 22 seem to be allowed. If your image doesn't has that, then try adding rule for port 22 in the default security group, and create new instance using the 'default' security group.

I cannot know what your current setup is.. what do you get when trying "ssh xxx.xxx.xxx.xxx" with the instance IP? is it "No route to host" ? Or other? If nothing helps.. try connecting to the instance using virt-manager, and look what's there in the iptables... or wherever the ip rules are..

edit flag offensive delete link more
0

answered 2012-05-10 16:42:29 -0500

yes,I had create instance with the default image used in the openstack install guide diablo ( download from http://images.ansolabs.com/tty.tgz ) , then I had add rule for port 22 in the default security group. I launch instance ,(I edit keypairs , default security groups and all is ok) ,this instance has ip ,status is active but I can't ssh it ,I have this error ssh: connect to x.x.x.x port 22 no route to host Thanks for your reply, I really need help because I was stopped with this issue

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2012-03-10 16:15:58 -0500

Seen: 141 times

Last updated: Jul 05 '12