Ask Your Question
0

Error during initial ring build.

asked 2010-10-22 21:57:26 -0500

software-cyberlynk gravatar image

This is my initial machine, initial install, initial build.

Running the follow command --

swift-ring-builder CyberLynkBuild create 9 3 24

produces this error ---

ImportError: No module named eventlet

edit retag flag offensive close merge delete

4 answers

Sort by ยป oldest newest most voted
0

answered 2010-10-22 22:41:40 -0500

cthier gravatar image

Eventlet needs to be installed.

This can be installed in Ubuntu Maverick with 'sudo apt-get install python-eventlet' or from our PPA for Ubuntu Lenny.

Other linux packaging systems may have it as well, and at the very least can be downloaded from: http://pypi.python.org/pypi/eventlet

edit flag offensive delete link more
0

answered 2010-10-25 14:08:39 -0500

software-cyberlynk gravatar image

The install package for Eventlet seems to be limited to version 10.10 and I am running 10.04 (recommended version). Should I be running 10.10? This is my first machine, my first install, and nothing is built yet, so going to 10.10 is not too much trouble.

edit flag offensive delete link more
0

answered 2010-10-25 15:02:27 -0500

cthier gravatar image

If you are running Ubuntu 10.04 then you can install eventlet from our PPA here:

https://launchpad.net/~swift-core/+archive/ppa (https://launchpad.net/~swift-core/+ar...)

edit flag offensive delete link more
0

answered 2010-10-25 16:18:04 -0500

software-cyberlynk gravatar image

Thanks Chuck Thier, that solved my question.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2010-10-22 21:57:26 -0500

Seen: 49 times

Last updated: Oct 25 '10