Ask Your Question
0

upload a kernel error

asked 2012-05-02 14:41:15 -0500

xieyf gravatar image

i upload a kernel use command "glance --os_username=adminUser --os_password=nihao --os_tenant=openstackDemo --os_auth_url=http://127.0.0.1:5000/v2.0 add name="tty-linux-kernel" disk_format=aki container_format=aki < ttylinux-uec-amd64-12.1_2.6.35-22_1-vmlinuz" .but get information "Failed to add image. Got error:Response from Keystone does not contain a Glance endpoint..Note: Your image metadata may still be in the registry, but the image's status will likely be 'killed'". please help me

edit retag flag offensive close merge delete

7 answers

Sort by ยป oldest newest most voted
0

answered 2012-08-13 04:16:25 -0500

danielnuneze gravatar image

Dear nihao

how do you solved it? I have the same problem.

edit flag offensive delete link more
0

answered 2012-08-19 23:35:44 -0500

digitalwonk gravatar image

I'm encountering the same problem. I would be interested in the solution, too.

Thanks, Ed

edit flag offensive delete link more
0

answered 2012-08-20 13:24:57 -0500

digitalwonk gravatar image

Sadly, after posting this, I had a typo in my keystone database after having to resort to the python debugger. You have to ensure you that your os_parameters (or OS_ env) are exactly right for it to work.

Here is the minimum set of OS_* environment I needed for glance to work: OS_TENANT_NAME OS_USERNAME OS_PASSWORD OS_AUTH_URL

One thing I found a little frustrating is that the glance client does not accept the same parameters as the keystone client in this regard. For example, I needed to use names instead of the ids (e.g. tenant name vs. tenant id). Another thing that is a little confusing is that if you define os_ name AND id, it's not clear to the user which one is used, and this could cause the user to get a bad catalog list or invalid authentication.

To verify that you have the right environment or settings, use "keystone catalog" (or "keystone catalog --service image") with the same environment. A successful call should result in the list service endpoints.

As a note to the developers, it would be nice if the command-line tools would produce more information, such as the settings used to authenticate particularly if debugging is enabled.

edit flag offensive delete link more
0

answered 2012-08-23 08:33:33 -0500

jaypipes gravatar image

Hi DigitalWonk,

The inconsistencies with the parameters are addressed in the next-generation client ( http://github.com/openstack/python-gl... ). The old glance client will be deprecated in the Grizzly release cycle.

Best, -jay

edit flag offensive delete link more
0

answered 2012-05-02 15:08:13 -0500

eglynn gravatar image

Have you tried creating the glance endpoint in the keystone catalog?

e.g.:

$ GLANCE_HOST=<your_glance_host> $ keystone-manage endpointTemplates add RegionOne glance http://$GLANCE_HOST:9292/v1 http://$GLANCE_HOST:9292/v1 http://$GLANCE_HOST:9292/v1 1 1

edit flag offensive delete link more
0

answered 2012-05-03 01:56:44 -0500

xieyf gravatar image

I created the glance ednpoint by use the command "keystone --token ADMIN --endpoint http://192.168.32.123:35357/v2.0 user-create --tenant_id eebbdcb86e644c7297b9d443702987f5 --name glance --pass nihao --enabled true",if do something wrong . I use the openstack-install-guide-trunk[1] installed it .

edit flag offensive delete link more
0

answered 2012-05-03 05:03:26 -0500

xieyf gravatar image

tkanks everyone , i have solved it ,the reason is because when i use keystone i make some mistake!

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2012-05-02 14:41:15 -0500

Seen: 19 times

Last updated: Aug 23 '12