Ask Your Question
0

failed to create network by dashboard

asked 2013-10-31 06:23:22 -0600

ryan-yi-liu gravatar image

1.Create a network by command 'neutron net-create' with parameter '--tenant-id' is OK.

neutron net-create --tenant-id 42b15ed7cc7d4986a1cc1ccdda844eca test_net

Created a new network: +---------------------------+--------------------------------------+ | Field | Value | +---------------------------+--------------------------------------+ | admin_state_up | True | | id | cccb503b-03f7-4ac3-a8c2-82dd7f1c945b | | name | test_net | | provider:network_type | vlan | | provider:physical_network | physnet1 | | provider:segmentation_id | 3 | | shared | False | | status | ACTIVE | | subnets | | | tenant_id | 42b15ed7cc7d4986a1cc1ccdda844eca | +---------------------------+--------------------------------------+

2.Create a network by command 'neutron net-create' without parameter '--tenant-id' , failed!

neutron net-create test_net

Running without keystone AuthN requires that tenant_id is specified

3.create network on dashboard, failed, error message as below: Error: Failed to create network "test_net": Running without keystone AuthN requires that tenant_id is specified

However, there is no place to set tenant_id when create a network on dashboard!!!

I think the tenant_id should be included in the request context?? But how?

edit retag flag offensive close merge delete

3 answers

Sort by ยป oldest newest most voted
0

answered 2013-11-04 02:40:26 -0600

ryan-yi-liu gravatar image

Thanks yong sheng gong, that solved my question.

edit flag offensive delete link more
0

answered 2013-11-02 09:04:31 -0600

gongysh gravatar image

aren't u are using keystone as authentication module?

neutron.conf: [DEFAULT] auth_strategy = keystone

edit flag offensive delete link more
0

answered 2013-11-02 09:32:54 -0600

amotoki gravatar image

OpenStack Dashboard is expected to use keystone-enabled OpenStack. When creating a network, Dashboard passes keystone token to Neutron and Neutron retrieves tenant_id or other information such as roles from Keystone based on the passed token.

I believe yong's suggestion will address your problem. It seems you already enable keystone because you succeed to login Dashboard, but it seems neutron is not configured to use keystone.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-10-31 06:23:22 -0600

Seen: 2,695 times

Last updated: Nov 04 '13