Ask Your Question
0

OpenStack Multiple Node Configuration. Second Node Can't Ping Its Instances

asked 2011-05-17 17:39:12 -0500

steven-haddix gravatar image

I am currently trying to setup an OpenStack multi-node network. I have a two computers, compute1 and compute2.

Compute1: nova-network, nova-scheduler, and nova-compute Compute2: nova-compute

The network is setup to run flatDHCP on a 192.168.0.* network. I am able to get Compute1 to launch instances and ssh into them, but I cannot ssh into the instances from any other computer. Also I am unable ssh into instances that are launched from Compute2.

Compute1: ifconfig

br100 Link encap:Ethernet HWaddr fe:16:3e:31:e6:b5
inet addr:192.168.0.33 Bcast:192.168.0.39 Mask:255.255.255.248 inet6 addr: fe80::b49e:82ff:fe61:f52d/64 Scope:Link UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:7341 errors:0 dropped:0 overruns:0 frame:0 TX packets:7526 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:0 RX bytes:1517824 (1.5 MB) TX bytes:1118721 (1.1 MB)

eth0 Link encap:Ethernet HWaddr 00:21:97:13:08:f4
inet addr:192.168.0.2 Bcast:192.168.0.255 Mask:255.255.255.0 inet6 addr: fe80::221:97ff:fe13:8f4/64 Scope:Link UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:16237962 errors:0 dropped:0 overruns:0 frame:0 TX packets:24821470 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:1234271649 (1.2 GB) TX bytes:34132269792 (34.1 GB) Interrupt:42 Base address:0x8000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0 inet6 addr: ::1/128 Scope:Host UP LOOPBACK RUNNING MTU:16436 Metric:1 RX packets:63698149 errors:0 dropped:0 overruns:0 frame:0 TX packets:63698149 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:0 RX bytes:5254017459 (5.2 GB) TX bytes:5254017459 (5.2 GB)

virbr0 Link encap:Ethernet HWaddr 6e:84:68:41:b7:8a
inet addr:192.168.122.1 Bcast:192.168.122.255 Mask:255.255.255.0 UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:0 errors:0 dropped:0 overruns:0 frame:0 TX packets:0 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:0 RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

vnet0 Link encap:Ethernet HWaddr fe:16:3e:31:e6:b5
inet6 addr: fe80::fc16:3eff:fe31:e6b5/64 Scope:Link UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:0 errors:0 dropped:0 overruns:0 frame:0 TX packets:12 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:500 RX bytes:0 (0.0 B) TX bytes:864 (864.0 B)

Compute1: nova.conf

--dhcpbridge_flagfile=/etc/nova/nova.conf --dhcpbridge=/usr/bin/nova-dhcpbridge --logdir=/var/log/nova --state_path=/var/lib/nova --lock_path=/var/lock/nova --verbose --sql_connection=mysql://root:password@192.168.0.2/nova --s3_host=192.168.0.2 --rabbit-host=192.168.0.2 --cc_host=192 ... (more)

edit retag flag offensive close merge delete

4 answers

Sort by ยป oldest newest most voted
0

answered 2011-05-17 17:56:02 -0500

steven-haddix gravatar image

So on compute2, --flat_interface should be eth0?

edit flag offensive delete link more
0

answered 2011-05-17 18:09:33 -0500

steven-haddix gravatar image

Problem Solved.

Compute1: added --flat_interface=eth1, --public_interface=eth0, --flat_injected=false to nova.conf

Compute2: Turned up eth1

edit flag offensive delete link more
0

answered 2011-05-17 18:10:13 -0500

steven-haddix gravatar image

Thanks Vish Ishaya, that solved my question.

edit flag offensive delete link more
0

answered 2011-05-17 17:50:32 -0500

vishvananda gravatar image

It looks like you only have eth0 active so setting --flat_interface=eth1 will not work

Vish

On May 17, 2011, at 10:41 AM, Steven wrote:

New question #157925 on OpenStack Compute (nova): https://answers.launchpad.net/nova/+q...

I am currently trying to setup an OpenStack multi-node network. I have a two computers, compute1 and compute2.

Compute1: nova-network, nova-scheduler, and nova-compute Compute2: nova-compute

The network is setup to run flatDHCP on a 192.168.0.* network. I am able to get Compute1 to launch instances and ssh into them, but I cannot ssh into the instances from any other computer. Also I am unable ssh into instances that are launched from Compute2.

Compute1: ifconfig

br100 Link encap:Ethernet HWaddr fe:16:3e:31:e6:b5
inet addr:192.168.0.33 Bcast:192.168.0.39 Mask:255.255.255.248 inet6 addr: fe80::b49e:82ff:fe61:f52d/64 Scope:Link UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:7341 errors:0 dropped:0 overruns:0 frame:0 TX packets:7526 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:0 RX bytes:1517824 (1.5 MB) TX bytes:1118721 (1.1 MB)

eth0 Link encap:Ethernet HWaddr 00:21:97:13:08:f4
inet addr:192.168.0.2 Bcast:192.168.0.255 Mask:255.255.255.0 inet6 addr: fe80::221:97ff:fe13:8f4/64 Scope:Link UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:16237962 errors:0 dropped:0 overruns:0 frame:0 TX packets:24821470 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:1234271649 (1.2 GB) TX bytes:34132269792 (34.1 GB) Interrupt:42 Base address:0x8000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0 inet6 addr: ::1/128 Scope:Host UP LOOPBACK RUNNING MTU:16436 Metric:1 RX packets:63698149 errors:0 dropped:0 overruns:0 frame:0 TX packets:63698149 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:0 RX bytes:5254017459 (5.2 GB) TX bytes:5254017459 (5.2 GB)

virbr0 Link encap:Ethernet HWaddr 6e:84:68:41:b7:8a
inet addr:192.168.122.1 Bcast:192.168.122.255 Mask:255.255.255.0 UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:0 errors:0 dropped:0 overruns:0 frame:0 TX packets:0 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:0 RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

vnet0 Link encap:Ethernet HWaddr fe:16:3e:31:e6:b5
inet6 addr: fe80::fc16:3eff:fe31:e6b5/64 Scope:Link UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:0 errors:0 dropped:0 overruns:0 frame:0 TX packets:12 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:500 RX bytes:0 (0.0 B) TX bytes:864 (864.0 B)

Compute1: nova.conf

--dhcpbridge_flagfile=/etc/nova/nova ...

(more)
edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2011-05-17 17:39:12 -0500

Seen: 63 times

Last updated: May 17 '11