Ask Your Question
2

How to solve broken dependencies for Swift RPM packages?

asked 2013-06-20 13:27:59 -0500

osyahoo2013 gravatar image

updated 2013-06-25 09:54:29 -0500

smaffulli gravatar image

yum install has lot of python dependencies, can someone please help?

Error: Package: 1:python-keystoneclient-0.2.3-4.el6.noarch (epel-openstack-grizzly)
           Requires: python-argparse
Error: Package: 1:python-oslo-config-1.1.0-1.el6.noarch (epel-openstack-grizzly)
           Requires: python-argparse
Error: Package: openstack-swift-1.8.0-2.el6.noarch (epel-openstack-grizzly)
           Requires: openstack-swift-plugin-swift3
Error: Package: 1:python-keystoneclient-0.2.3-4.el6.noarch (epel-openstack-grizzly)
           Requires: python-prettytable
Error: Package: 1:python-keystoneclient-0.2.3-4.el6.noarch (epel-openstack-grizzly)
           Requires: python-requests >= 0.8.8
Error: Package: openstack-swift-1.8.0-2.el6.noarch (epel-openstack-grizzly)
           Requires: python-netifaces
Error: Package: openstack-swift-1.8.0-2.el6.noarch (epel-openstack-grizzly)
           Requires: python-eventlet >= 0.9.8
Error: Package: 1:python-keystoneclient-0.2.3-4.el6.noarch (epel-openstack-grizzly)
           Requires: python-keyring
Error: Package: openstack-swift-1.8.0-2.el6.noarch (epel-openstack-grizzly)
           Requires: python-paste-deploy1.5
Error: Package: 1:python-keystoneclient-0.2.3-4.el6.noarch (epel-openstack-grizzly)
           Requires: python-iso8601 >= 0.1.4
Error: Package: openstack-swift-1.8.0-2.el6.noarch (epel-openstack-grizzly)
           Requires: python-greenlet >= 0.3.1
Error: Package: openstack-swift-1.8.0-2.el6.noarch (epel-openstack-grizzly)
           Requires: pyxattr
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
[root@hostname16 ~]#
edit retag flag offensive close merge delete

Comments

have you enabled many different installation repositories? I had this kind of message once while rpmforge and epel are both enabled at the same time.

If it is not the case, you can try to install the packets required manually.

Vic gravatar imageVic ( 2013-06-21 02:57:46 -0500 )edit

have the exactly same issue here on fresh install of CentOS 6.4

n-paladi gravatar imagen-paladi ( 2013-07-05 10:10:43 -0500 )edit

3 answers

Sort by ยป oldest newest most voted
3

answered 2013-06-22 07:23:24 -0500

Henk gravatar image

updated 2013-06-24 02:52:45 -0500

It is unclear if you are on Red Hat, CentOS, Fedora or any other RPM-based linux-distribution.
But indeed as Vic kind of points out, have you enabled (at least) the EPEL repository?
Have a look at Getting started with OpenStack EPEL, "Enable EPEL repositories", how to get going.

Furtheron, use this guide as a reference: OpenStack Installation Guide for Red Hat Enterprise Linux, CentOS, and Fedora

This guide shows you how to install OpenStack by using packages available through Fedora 17 as well as on RHEL and derivatives through the EPEL repository.

edit flag offensive delete link more
3

answered 2013-07-05 10:24:59 -0500

n-paladi gravatar image

updated 2013-07-05 10:26:26 -0500

As mentioned in the comment, had the exact same issue when following the http://docs.openstack.org/trunk/openstack-compute/install/yum/content/install-keystone.html (installation guide) on a CentOS 6.4

Adding the epel repository solved the issue:

  • Download the latest epel-release rpm from:

http://dl.fedoraproject.org/pub/epel/6/i386/

  • Install epel-release rpm:

rpm -Uvh epel-release*rpm

The http://docs.openstack.org/trunk/openstack-compute/install/yum/content/install-keystone.html (installation guide) should be updated imo

edit flag offensive delete link more

Comments

1

answered 2013-06-24 03:48:40 -0500

david-hadas gravatar image

updated 2013-06-25 09:52:51 -0500

smaffulli gravatar image

It is highly desired to use one of the packages that already support openstack, which are best tested.

https://wiki.openstack.org/wiki/SwiftInstall

If you use a different package, you will need to deal with the dependency issues.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2013-06-20 13:27:59 -0500

Seen: 1,821 times

Last updated: Jul 05 '13