Ask Your Question
1

Quantum DHCP Issue

asked 2013-06-20 04:01:47 -0600

Umar Draz gravatar image

Hi All,

I am running Multinode Grizzly with Quantum, everything is every fine but quantum dhcp not allocating ip to virtual machine.

Here is the virtual machine logs

cloudinitnonet gave up waiting for a network device.

ciinfo: lo : 1 127.0.0.1 255.0.0.0 .

ciinfo: eth0 : 1 . . fa:16:3e:a8:25:b3

route_info failed

Waiting for network configuration...

and here is my dhcpdump of quantum

IP: 0.0.0.0 (fa:16:3e:a8:25:b3) > 255.255.255.255 (ff:ff:ff:ff:ff:ff)

OP: 1 (BOOTPREQUEST)

HTYPE: 1 (Ethernet)

HLEN: 6

HOPS: 0

XID: dce12904

SECS: 169

FLAGS: 0

CIADDR: 0.0.0.0

YIADDR: 0.0.0.0

SIADDR: 0.0.0.0

GIADDR: 0.0.0.0

CHADDR: fa:16:3e:a8:25:b3:00:00:00:00:00:00:00:00:00:00

Anybody help me how to solve this issue?

Br.

Umar

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
1

answered 2013-06-20 10:40:10 -0600

armando-migliaccio gravatar image

updated 2013-06-20 10:40:30 -0600

There's very little information to give you any sort of useful input. However it seems like your VM's and DHCP agent cannot see each other, and this may be for a number of reasons. In order to troubleshoot this further we would need to understand your network topology and what quantum plugins you are using. Please provide things like:

  • config files
  • log files
  • host networking configs (e.g. if you are using ovs, a dump of ovs-vsctl show would be really useful, especially on the dhcp side).
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2013-06-20 04:01:47 -0600

Seen: 181 times

Last updated: Jun 20 '13