Ask Your Question
0

provider network vlan tag numbers

asked 2013-03-02 06:58:14 -0600

sudhakaroq gravatar image

I am using devstack single node installation with quantum enabled for my openstack learning and quantum plugin development. When I create provider vlan networks with particular segment number and some ports on them, I observed tag numbers on br-int are not same as my network segment numbers. Am I missing something here or my configuration for provider networks is wrong? My localrc:

disable_service n-net enable_service q-svc enable_service q-agt enable_service q-dhcp enable_service q-l3 enable_service q-meta enable_service quantum

ENABLE_TENANT_VLANS=True TENANT_VLAN_RANGE=1:1999 PHYSICAL_NETWORK=default OVS_PHYSICAL_BRIDGE=br-Test

mysql> select * from ovs_network_bindings; +--------------------------------------+--------------+------------------+-----------------+ | network_id | network_type | physical_network | segmentation_id | +--------------------------------------+--------------+------------------+-----------------+ | 9414d425-0bba-4d01-92da-11a725143cea | vlan | default | 2 | | d14e28b5-715c-42c3-b8f0-ba53538c05f3 | vlan | default | 50 | | d8852047-435e-485e-8bd6-c82d487d0992 | vlan | default | 1 | +--------------------------------------+--------------+------------------+-----------------+

root@ubuntu:/opt/stack/devstack# ovs-vsctl show 3a7b5c2c-539b-4325-99a3-32cea4acf646 Bridge br-Test Port br-Test Interface br-Test type: internal Port phy-br-Test Interface phy-br-Test Bridge br-ex Port br-ex Interface br-ex type: internal Port "qg-06a68938-de" Interface "qg-06a68938-de" type: internal Bridge br-int Port "tap72d47fb2-fa" tag: 2 Interface "tap72d47fb2-fa" type: internal Port br-int Interface br-int type: internal Port "qvo1caa86ef-9a" tag: 3 Interface "qvo1caa86ef-9a" Port "tapd73218b5-d2" tag: 1 Interface "tapd73218b5-d2" type: internal Port int-br-Test Interface int-br-Test Port "qvo87646ffd-1a" tag: 2 Interface "qvo87646ffd-1a" Port "qr-777e5d43-f8" tag: 1 Interface "qr-777e5d43-f8" type: internal ovs_version: "1.4.3"

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2013-03-03 13:10:56 -0600

sudhakaroq gravatar image

Thanks dan wendlandt, that solved my question.

edit flag offensive delete link more
0

answered 2013-03-03 02:37:08 -0600

danwent gravatar image

no, this is expected behavior. the VLAN that exists on br-int will be mapped to the correct vlan when the packet is sent out a particular external bridge. This is done for two reasons:

1) its possible that the same vlan ID is being used on two different bridges 2) vlans are used within br-int even when tunneling is used for communcation between hosts.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-03-02 06:58:14 -0600

Seen: 69 times

Last updated: Mar 03 '13