Ask Your Question
0

No route for /v1/images

asked 2012-04-13 22:17:39 -0500

nicolas2bonfils gravatar image

Hi all,

When I want to list glance images (with CLI or horizon dashboard), glance failed telling that there is no route for the request. Extract from glance-api.log : 2012-04-14 00:04:25 11259 DEBUG [glance.api.middleware.version_negotiation] Determining version of request: GET /v1/images Accept: 2012-04-14 00:04:25 11259 DEBUG [glance.api.middleware.version_negotiation] Using url versioning 2012-04-14 00:04:25 11259 DEBUG [glance.api.middleware.version_negotiation] Matched version: v1 2012-04-14 00:04:25 11259 DEBUG [glance.api.middleware.version_negotiation] new uri /v1/images 2012-04-14 00:04:25 11259 DEBUG [keystone.middleware.auth_token] Authenticating user token 2012-04-14 00:04:25 11259 DEBUG [keystone.middleware.auth_token] Removing headers from request environment: X-Identity-Status,X-Tenant-Id,X-Tenant-Name,X-User-Id,X-User-Name,X-Roles,X-User,X-Tenant,X-Role 2012-04-14 00:04:25 11259 DEBUG [routes.middleware] No route matched for GET /v1/images 2012-04-14 00:04:25 11259 DEBUG [eventlet.wsgi.server] 192.168.23.5 - - [14/Apr/2012 00:04:25] "GET /v1/images?limit=10 HTTP/1.1" 404 176 0.019211

It works few days ago, I didn't change config since, only recheck code from github with devstack. I reset 2 times : - first running devstack again, - second, all from scratch. Also reboot the server. No changes.

Anyone got ideas why it failed ? Thanks

edit retag flag offensive close merge delete

6 answers

Sort by ยป oldest newest most voted
0

answered 2012-04-17 08:53:27 -0500

s-rain gravatar image

Can you paste your keystone endpoint-list?

edit flag offensive delete link more
0

answered 2012-04-17 13:03:32 -0500

nicolas2bonfils gravatar image

After multiple reset, the problem disappear.

edit flag offensive delete link more
0

answered 2012-04-14 22:26:47 -0500

Try dropping 'v1' from the end of your service catalog entries for your image service.

edit flag offensive delete link more
0

answered 2012-04-15 20:22:32 -0500

nicolas2bonfils gravatar image

HI,

I try and I got a http 300 multiple choice. I also try to put v2, but got the same problem.

edit flag offensive delete link more
0

answered 2012-04-14 07:29:22 -0500

nicolas2bonfils gravatar image

Hi,

All here : https://gist.github.com/2382627 (in the filename, I add .ini to have syntax coloration)

Thanks

edit flag offensive delete link more
0

answered 2012-04-14 02:54:29 -0500

gongysh gravatar image

Can you put your keystone.conf, glance-api-paste.ini here?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2012-04-13 22:17:39 -0500

Seen: 47 times

Last updated: Apr 17 '12