start nova-compute failure

asked 2012-09-21 09:42:09 -0600

Hi experts,

when I run the command(nova-manage service list), I get the below output root@Userver2:~# nova-manage service list 2012-09-21 17:36:49 DEBUG nova.utils [req-db670af0-2d15-4607-a23d-72dd7d97cb0d None None] backend from (pid=10876) __get_backend /usr/lib/python2.7/dist-packages/nova/utils.py:658 Binary Host Zone Status State Updated_At nova-consoleauth http://userver1.matrix.com nova enabled :-) 2012-09-21 09:36:45 nova-compute http://userver1.matrix.com nova enabled XXX 2012-09-21 01:38:53 nova-compute Userver2 nova enabled :-) 2012-09-21 09:36:42 nova-volume http://userver1.matrix.com nova enabled :-) 2012-09-21 09:36:49 nova-network http://userver1.matrix.com nova enabled :-) 2012-09-21 09:36:42 nova-scheduler http://userver1.matrix.com nova enabled :-) 2012-09-21 09:36:41 nova-cert http://userver1.matrix.com nova enabled :-) 2012-09-21 09:36:48

I noticed that the nova-compute serice can not start. then I run the command (start nova-compute), and I get the following error in the /var/log/nova/nova-compute.log.

2012-09-21 17:29:52 TRACE nova File "/usr/lib/python2.7/dist-packages/nova/exception.py", line 114, in wrapped 2012-09-21 17:29:52 TRACE nova return f(args, *kw) 2012-09-21 17:29:52 TRACE nova File "/usr/lib/python2.7/dist-packages/nova/virt/libvirt/connection.py", line 718, in reboot 2012-09-21 17:29:52 TRACE nova if self._soft_reboot(instance): 2012-09-21 17:29:52 TRACE nova File "/usr/lib/python2.7/dist-packages/nova/virt/libvirt/connection.py", line 754, in _soft_reboot 2012-09-21 17:29:52 TRACE nova dom.create() 2012-09-21 17:29:52 TRACE nova File "/usr/lib/python2.7/dist-packages/libvirt.py", line 551, in create 2012-09-21 17:29:52 TRACE nova if ret == -1: raise libvirtError ('virDomainCreate() failed', dom=self) 2012-09-21 17:29:52 TRACE nova libvirtError: Unable to allow access for disk path /dev/disk/by-path/ip-192.168.172.14:3260-iscsi-iqn.2010-10.org.openstack:volume-00000004-lun-1: No such file or directory 2012-09-21 17:29:52 TRACE nova

Did anyone encounter the same issues?

pls give me some advice to fix it Any help would be appreciated.

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2012-09-24 01:55:50 -0600

the issuse have benn solved. I changed the resume_guests_state_on_host_boot=true and start_guests_on_host_boot=true.

thanks for Yaguang Tang help

edit flag offensive delete link more
0

answered 2012-09-22 14:47:36 -0600

heut2008 gravatar image

the reason is that the instance mounts a remote volume before, but duo to some reason, now the volume is not exists in the server. so the instance can't be started, also in your nova.conf I guess you set the resume_guests_state_on_host_boot=true or start_guests_on_host_boot=true .so nova-compute can't start .

you can change the two config options to false to prevent nova-compute from start the instances at startup time. or mount the remove volume manually by using iscsiadm

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2012-09-21 09:42:09 -0600

Seen: 63 times

Last updated: Sep 24 '12