Ask Your Question
0

glance+swift StoreAddDisabled issue

asked 2012-06-29 09:14:12 -0500

longeek gravatar image

Hi, I deploy glance(192.168.220.152) with swift+swauth(192.168.220.151). After I finish it and test, I get StoreAddDisabled issue in glance-api.log. At Server 192.168.220.152: -------------glance-api.conf------------ http://paste.openstack.org/show/19022/

-------------glance-api.log-------------- http://paste.openstack.org/show/19023/

At Server 192.168.220.151 ------- -----swift test command------- http://paste.openstack.org/show/19024/

-------------proxy-server.conf---------- http://paste.openstack.org/show/19025/

and swauth-prep -K swauthkey swauth-add-user -A http://127.0.0.1:8080/auth/ -K swauthkey -a test tester testing OK

Can anyone help me ?

Regards,

Lawrence

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2012-07-02 09:45:14 -0500

In your config file you have :

swift_store_auth_address = http://192.168.220.151:8080/v1

it should probably be :

swift_store_auth_address = http://192.168.220.151:8080/v1.0/

as mentioned by the documentation.

(I am not entirely sure since I haven't used swauth for a while).

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2012-06-29 09:14:12 -0500

Seen: 61 times

Last updated: Jul 02 '12