Ask Your Question
0

Multi-node: nova-volume and nova-compute

asked 2011-08-22 20:10:03 -0500

gagupta gravatar image

I have 2 hosts, running all the nova services:

Host1:

root@Host1:cred# nova-manage service list Binary Host Zone Status State Updated_At nova-scheduler Host1 nova enabled :-) 2011-08-22 20:00:57.966621 nova-network Host1 nova enabled :-) 2011-08-22 20:00:57.837392 nova-vncproxy Host1 nova enabled :-) 2011-08-22 20:00:49.865538 nova-compute Host1 nova enabled :-) 2011-08-22 20:00:56.447137

Host2:

root@Host2:cred# nova-manage service list Binary Host Zone Status State Updated_At nova-scheduler Host2 nova enabled :-) 2011-08-22 20:03:05.654425 nova-volume Host2 nova enabled :-) 2011-08-22 20:02:58.396701 nova-network Host2 nova enabled :-) 2011-08-22 20:03:04.137767 nova-compute Host2 nova enabled :-) 2011-08-22 20:03:04.231711 nova-vncproxy Host2 nova enabled :-) 2011-08-22 20:03:05.536724

Only Host2 is running the nova-volume service. On Host2, I can successfully create/attach/detach volumes to the instances running on the same host. How do I update the nova configuration on Host1 to access volumes on Host2?

nova-volumes is configured to use iscsitarget and LVM volumes. Here is my nova.conf for Host2: --verbose --nodaemon --dhcpbridge_flagfile=/home/admin/openstack/nova/bin/nova.conf --network_manager=nova.network.manager.VlanManager --my_ip=192.168.1.199 --public_interface=eth0 --vlan_interface=eth0 --sql_connection=sqlite:////home/admin/openstack/nova/nova.sqlite --auth_driver=nova.auth.dbdriver.DbDriver --libvirt_type=qemu --osapi_extensions_path=/home/admin/openstack/openstackx/extensions --vncproxy_url=http://192.168.1.199:6080 --vncproxy_wwwroot=/home/admin/openstack/noVNC/noVNC --api_paste_config=/home/admin/openstack/keystone/examples/paste/nova-api-paste.ini --image_service=nova.image.glance.GlanceImageService --state_path=/home/admin/openstack/nova/CA --iscsi_ip_prefix=192.168. --logdir=/var/log/nova

edit retag flag offensive close merge delete

1 answer

Sort by » oldest newest most voted
0

answered 2011-08-22 21:49:38 -0500

gagupta gravatar image

All I had to do is update nova.conf on Host1 and restart the compute service on Host1. Here are two flags that I changed: --my_ip=192.168.1.199 --iscsi_ip_prefix=192.168.

In addition to this, I had to change the novarc file on Host1 to point to Host2, otherwise commands will fail with an authentication error.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2011-08-22 20:10:03 -0500

Seen: 48 times

Last updated: Aug 22 '11