Ask Your Question
0

Internal Server Error 500+503 / Object-Store - Essex

asked 2012-11-21 20:23:13 -0600

tatenda-mupaso gravatar image

Okay so I'm currently having a problem with swift after installing it. I'm testing in a VMWare environment right now and I made a separate VM specifically for running Swift. Installed and configured and I went through the installation with no problem, ( swift-account, swift-object, swift-container, proxy, remakerings etc etc.)

First problem I noticed is when I did:

#sudo service swift-object restart stop: Unknown instance: [OK] start: Job failed to start

That was my first uh oh moment. Then I ran a swift test after restarting everything, I tried to ignore the problem but it seemed to only get worse when I added swift to my Keystone Identity service (including endpoint), everything went downhill from there..

root@ubuntu:# swift -V 2.0 -A http://172.16.0.1:5000/v2.0/ -U cookbook:demo -K openstack stat Auth GET failed: http://172.16.0.1:5000/v2.0/tokens 500 Internal Server Error

Here are some of the things you might find helpful in helping me


remake rings bash

root@ubuntu:/home/swift# leafpad /usr/local/bin/remakerings root@ubuntu:/home/swift# sudo /usr/local/bin/remakerings Device z1-127.0.0.1:6010/sdb1_"" with 1.0 weight got id 0 Device z2-127.0.0.1:6020/sdb2_"" with 1.0 weight got id 1 Device z3-127.0.0.1:6030/sdb3_"" with 1.0 weight got id 2 Device z4-127.0.0.1:6040/sdb4_"" with 1.0 weight got id 3 Reassigned 262144 (100.00%) partitions. Balance is now 0.00. Device z1-127.0.0.1:6011/sdb1_"" with 1.0 weight got id 0 Device z2-127.0.0.1:6021/sdb2_"" with 1.0 weight got id 1 Device z3-127.0.0.1:6031/sdb3_"" with 1.0 weight got id 2 Device z4-127.0.0.1:6041/sdb4_"" with 1.0 weight got id 3 Reassigned 262144 (100.00%) partitions. Balance is now 0.00. Device z1-127.0.0.1:6012/sdb1_"" with 1.0 weight got id 0 Device z2-127.0.0.1:6022/sdb2_"" with 1.0 weight got id 1 Device z3-127.0.0.1:6032/sdb3_"" with 1.0 weight got id 2 Device z4-127.0.0.1:6042/sdb4_"" with 1.0 weight got id 3 Reassigned 262144 (100.00%) partitions. Balance is now 0.00.


authtoken

root@ubuntu:/home/swift# curl -v -H 'X-Storage-User: test:tester' -H 'X-Storage-Pass: testing' http://127.0.0.1:8080/auth/v1.0 * About to connect() to 127.0.0.1 port 8080 (#0) * Trying 127.0.0.1... connected

GET /auth/v1.0 HTTP/1.1 User-Agent: curl/7.22.0 (x86_64-pc-linux-gnu) libcurl/7.22.0 OpenSSL/1.0.1 zlib/1.2.3.4 libidn/1.23 librtmp/2.3 Host: 127.0.0.1:8080 Accept: / X-Storage-User: test:tester X-Storage-Pass: testing

< HTTP/1.1 200 OK < X-Storage-Url: http://127.0.0.1:8080/v1/AUTH_test < X-Storage-Token: AUTH_tk38b27e0f2e4c474d9d2709cd31ec01d4 < X-Auth-Token: AUTH_tk38b27e0f2e4c474d9d2709cd31ec01d4 < Content-Length: 0 < Date: Tue, 20 Nov 2012 16:31:25 GMT < * Connection ...

(more)
edit retag flag offensive close merge delete

3 answers

Sort by ยป oldest newest most voted
0

answered 2013-01-10 14:00:21 -0600

Hi - Could you confirm what errors you found in your config files? I am encountering the same issue but all of my config files seem ok.

Thanks.

edit flag offensive delete link more
0

answered 2012-11-28 16:08:57 -0600

tatenda-mupaso gravatar image

Nevermind, solved. Config files had a couple of typos and i fixed everything. I have ran into another problem. I'll make another post

edit flag offensive delete link more
0

answered 2013-01-15 20:10:43 -0600

tatenda-mupaso gravatar image

Hi Craig, Sorry I am only seeing your email now. But I went back and REALLY scrutinized every configuration line in my config files and they were typo's. All Syntax errors on my part. I know it's a pain but I had to learn the hard way. I have moved onto Folsom now though, haven't gotten to the same problem now, because this was back when I was testing in Essex. Hopefully this helps. Let me know.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2012-11-21 20:23:13 -0600

Seen: 291 times

Last updated: Jan 15 '13