Ask Your Question
0

ERROR: [Errno 111] Connection refused when creating cinder volumes

asked 2013-06-17 13:10:33 -0600

brianfsu gravatar image

Setup OpenStack according to https://github.com/mseknibilel/OpenStack-Grizzly-Install-Guide/blob/master/OpenStack_Grizzly_Install_Guide.rst. I am having great difficulty creating cinder volumes.

When I run "cinder -- debug list" I get the following:

root@openstack:~# cinder --debug list
REQ: curl -i https://192.168.1.42/v2.0/tokens -X POST -H "Content-Type: application/json" -H "Accept: application/json" -H "User-Agent: python-cinderclient" -d '{"auth": {"tenantName": "admin", "passwordCredentials": {"username": "admin", "password": "admin_pass"}}}'

DEBUG (shell:495) [Errno 111] Connection refused
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/cinderclient/shell.py", line 490, in main
    OpenStackCinderShell().main(map(strutils.safe_decode, sys.argv[1:]))
  File "/usr/lib/python2.7/dist-packages/cinderclient/shell.py", line 435, in main
    self.cs.authenticate()
  File "/usr/lib/python2.7/dist-packages/cinderclient/v1/client.py", line 81, in authenticate
    self.client.authenticate()
  File "/usr/lib/python2.7/dist-packages/cinderclient/client.py", line 279, in authenticate
    auth_url = self._v2_auth(auth_url)
  File "/usr/lib/python2.7/dist-packages/cinderclient/client.py", line 336, in _v2_auth
    self._authenticate(url, body)
  File "/usr/lib/python2.7/dist-packages/cinderclient/client.py", line 357, in _authenticate
    allow_redirects=True)
  File "/usr/lib/python2.7/dist-packages/cinderclient/client.py", line 123, in request
    **kwargs)
  File "/usr/lib/python2.7/dist-packages/requests/api.py", line 44, in request
    return session.request(method=method, url=url, **kwargs)
  File "/usr/lib/python2.7/dist-packages/requests/sessions.py", line 279, in request
    resp = self.send(prep, stream=stream, timeout=timeout, verify=verify, cert=cert, proxies=proxies)
  File "/usr/lib/python2.7/dist-packages/requests/sessions.py", line 374, in send
    r = adapter.send(request, **kwargs)
  File "/usr/lib/python2.7/dist-packages/requests/adapters.py", line 206, in send
    raise ConnectionError(sockerr)
ConnectionError: [Errno 111] Connection refused
ERROR: [Errno 111] Connection refused
edit retag flag offensive close merge delete

Comments

I have seen this same error reported other times. Can you please check if there are already answers that work for you? If not, provide more details that make your problem different.

smaffulli gravatar imagesmaffulli ( 2013-06-17 15:49:38 -0600 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2013-06-17 15:59:29 -0600

brianfsu gravatar image

I just discovered the issue was with the environment variables I was using.

I followed this http://docs.openstack.org/cli/quick-start/content/getting_credentials_cli.html but didn't have the correct URL.

edit flag offensive delete link more

Comments

Okay, figured it out. Didn't have port 5000 specified for the OS_AUTH_URL variable. Set it to http://192.168.1.42:5000:/v2.0/ and now it's working great! Thanks.

brianfsu gravatar imagebrianfsu ( 2013-06-17 16:08:05 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2013-06-17 13:10:33 -0600

Seen: 2,323 times

Last updated: Jun 17 '13