Why do I see "Unable to find authentication token in headers" using swift with staticweb? [closed]

asked 2013-04-11 05:24:17 -0600

ChrisHuman gravatar image

updated 2013-04-25 17:47:13 -0600

smaffulli gravatar image

Hi, I've set up openstack swift using keystone auth and have set up a staticweb container. Everything works fine, but when I access content from the static container I get the following warning to STDOUT:

proxy-server STDOUT: WARNING:keystone.middleware.auth_token:Unable to find authentication token in headers: {'SCRIPT_NAME': '', 'REQUEST_METHOD': 'GET', 'PATH_INFO': '/v1/AUTH_XXXX/p/allgood.txt', 'SERVER_PROTOCOL': 'HTTP/1.0', 'HTTP_TE': 'deflate,gzip;q=0.3', 'HTTP_USER_AGENT': 'libwww-perl/5.805', 'HTTP_CONNECTION': 'close', 'eventlet.posthooks': [], 'SERVER_NAME': '192.168.101.18', 'REMOTE_ADDR': '192.168.101.18', 'eventlet.input': <eventlet.wsgi.Input object at 0x226de10>, 'wsgi.url_scheme': 'http', 'SERVER_PORT': '8888', 'wsgi.input': <eventlet.wsgi.Input object at 0x226de10>, 'HTTP_HOST': '192.168.101.18', 'wsgi.multithread': True, 'HTTP_ACCEPT': '*/*', 'wsgi.version': (1, 0), 'RAW_PATH_INFO': '/v1/AUTH_XXXX/p/allgood.txt', 'GATEWAY_INTERFACE': 'CGI/1.1', 'wsgi.run_once': False, 'wsgi.errors': <swift.common.utils.LoggerFileObject object at 0x2276210>, 'wsgi.multiprocess': False, 'swift.trans_id': 'txabd36c72704949699d79b3ae8e779d9e', 'CONTENT_TYPE': None, 'swift.cache': <swift.common.memcached.MemcacheRing object at 0x2301250>}

my proxy-server.conf:

[DEFAULT]
bind_port = 8888
workers = 8
user = swift

[pipeline:main]
pipeline = catch_errors healthcheck cache authtoken keystone staticweb proxy-logging proxy-server

[app:proxy-server]
use = egg:swift#proxy
allow_account_management = true
account_autocreate = true

[filter:cache]
use = egg:swift#memcache
memcache_servers = 127.0.0.1:11211

[filter:catch_errors]
use = egg:swift#catch_errors

[filter:healthcheck]
use = egg:swift#healthcheck

[filter:staticweb]
use = egg:swift#staticweb
set access_log_name = staticweb
set log_headers = False

[filter:keystone]
paste.filter_factory = keystone.middleware.swift_auth:filter_factory
operator_roles = admin, swiftoperator

[filter:authtoken]
paste.filter_factory = keystone.middleware.auth_token:filter_factory
delay_auth_decision = 1
service_host = 192.168.101.20
service_port = 5000
auth_host = 192.168.101.20
auth_port = 35357
auth_protocol = http
auth_uri = http://192.168.101.20:5000/
auth_token = xxxx
admin_token = xxxx
admin_tenant_name = service
admin_user = swift
admin_password = xxxxxx
signing_dir = /tmp/keystone-signing-swift

[filter:proxy-logging]
use = egg:swift#proxy_logging

As I said, I can access the files in the container perfectly well and there are no other problems. Any help would be appreciated.

Using openstack-swift-proxy-1.7.4-2.el6.noarch on centos 6.4 installed from EPEL

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by koolhead17
close date 2013-11-19 19:34:53.813373

1 answer

Sort by ยป oldest newest most voted
0

answered 2013-04-29 14:20:30 -0600

creiht gravatar image

This appears to be a bug in the keystone authtoken middleware. There is no need to print that warning, since the container is public accessible.

edit flag offensive delete link more

Comments

Thanks. This is what I was thinking. I've commented out the logging line in /usr/lib/python2.6/site-packages/keystone/middleware/auth_token.py for now to suppress the logging.

ChrisHuman gravatar imageChrisHuman ( 2013-04-30 04:57:34 -0600 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2013-04-11 05:24:17 -0600

Seen: 2,496 times

Last updated: Apr 29 '13