Keystone did not start

asked 2013-05-03 00:00:38 -0600

tjones-i gravatar image

I'm having the same issue reported in 226015 - I get an error that keystone cannot start.

on the console i have this

(eventlet.wsgi.server): 2013-05-02 16:06:04,911 DEBUG wsgi write (47964) wsgi starting up on http://0.0.0.0:35357/

(eventlet.wsgi.server): 2013-05-02 16:06:04,911 DEBUG wsgi write (47964) wsgi starting up on http://0.0.0.0:5000/

and it fails with this

2013-05-02 16:05:42 + timeout 60 sh -c 'while ! http_proxy= curl -s http://192.168.140.127:5000/v2.0/ >/dev/null; do sleep 1; done' 2013-05-02 16:06:37 + die 326 'keystone did not start'

but if i connect using firefox i get a response

<version status="stable" updated="2013-03-06T00:00:00Z" id="v2.0"><media-types><media-type base="application/json" type="application/vnd.openstack.identity-v2.0+json"/><media-type base="application/xml" type="application/vnd.openstack.identity-v2.0+xml"/></media-types><links><link href="http://localhost:5000/v2.0/" rel="self"/><link href="http://docs.openstack.org/api/openstack-identity-service/2.0/content/" type="text/html" rel="describedby"/><link href="http://docs.openstack.org/api/openstack-identity-service/2.0/identity-dev-guide-2.0.pdf" type="application/pdf" rel="describedby"/></links></version>

If i run the curl command by hand it hangs. Im sure this is a rookie problem but i am stuck - help appreciated.

edit retag flag offensive close merge delete

2 answers

Sort by » oldest newest most voted
0

answered 2013-05-03 00:41:15 -0600

tjones-i gravatar image

ah - I think it's my proxy interfering….

curl -s http://192.168.140.127:5000/v2 --verbose * About to connect() to proxy xxxxxx port yyyy (#0) * Trying 10.113.161.210... connected

GET http://192.168.140.127:5000/v2 HTTP/1.1 User-Agent: curl/7.22.0 (x86_64-pc-linux-gnu) libcurl/7.22.0 OpenSSL/1.0.1 zlib/1.2.3.4 libidn/1.23 librtmp/2.3 Host: 192.168.140.127:5000 Accept: / Proxy-Connection: Keep-Alive

edit flag offensive delete link more
0

answered 2013-05-06 17:42:31 -0600

tjones-i gravatar image

It was the proxy - i added no_proxy to my /etc/environment and it works fine

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-05-03 00:00:38 -0600

Seen: 98 times

Last updated: May 06 '13