Ask Your Question
3

Quantum LBaaS is too long to answer at HTTP requests (Grizzly)

asked 2013-06-16 17:50:36 -0500

Emilien Macchi gravatar image

Hi,

I've deployed Quantum LBaaS on a fresh OpenStack setup (Grizzly 2013.1.2) with HAproxy as the backend driver.

I created a simple LB with 2 webservers (apache2) in backend, associated the VIP to a floating IP and updated the security group port option to allow 80 tcp.

With "while true; do curl -q http://X.X.X.X:8080 && date; done" command, I can see that I get an answer from webserver every 15s which is too long for me.

I would like to know if someone already met this kind of issue, and if it's related to my setup or to Quantum LBaaS service ?

Thank's for support,

Emilien Macchi

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
1

answered 2013-10-16 09:42:57 -0500

rohara gravatar image

Did you create a healthmonitor and associate it with you pool? It is possible to observe slow responses when one of the pool members is down and no healthmonitor is associated with the pool. If the selected backend server is down, haproxy will retry N times before it the request is dispatched to a different backend server. When a healthmonitor is associated with the pool, no member that is down will be considered for the request.

edit flag offensive delete link more
-1

answered 2013-06-16 18:14:21 -0500

Salvatore gravatar image

It definitely too slow too be true, even by Quantum standards!

This kind of timeout makes me suspect your instances or haproxy are trying to perform some kind of dns resolution before sending the response. You might want to try with tcpdump on the server side.

edit flag offensive delete link more

Comments

You can see TCPdump here : http://oi39.tinypic.com/2rxtc9v.jpg

Emilien Macchi gravatar imageEmilien Macchi ( 2013-06-17 03:39:24 -0500 )edit

It seems that if I change net.ipv4.vs.timeout_timewait value (which is at 15) to 5, it takes 5s to answer.

Emilien Macchi gravatar imageEmilien Macchi ( 2013-06-17 09:42:25 -0500 )edit

The problem seems to be localized in the LBaaS namespace because when I spawn a VM with HAproxy & another with webserver, the HTTP requests are load balanced immediately.

Emilien Macchi gravatar imageEmilien Macchi ( 2013-06-17 12:09:42 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-06-16 17:50:36 -0500

Seen: 254 times

Last updated: Oct 16 '13