Ask Your Question
0

ceilometer-agent-compute gives a 401 on start-up

asked 2013-06-15 00:40:55 -0600

Jobin gravatar image

updated 2013-06-24 06:07:41 -0600

When I start-up my ceilometer-agent-compute, I get a long python stack trace, the last line of which gives this:

Unauthorized: The request you have made requires authentication. (HTTP 401)

I have set my ceilometer.conf as given here:

Ceilometer configuration documentation

And have not set HBase as my database, so have not used the configuration given.

What is going wrong here? Please have a look at the complete error message here:

The error message

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
3

answered 2013-06-17 01:18:46 -0600

Jobin gravatar image

updated 2013-07-07 23:29:41 -0600

Even though the documentation says that if an incorrect id is provided, keystone verifies access by looking up the user-name, password and tenant-name, it probably didn't do it for me.

I could get this solved by uncommenting the line os-tenant-id in the file /etc/ceilometer/ceilometer.conf.

There are some other tweaks/settings you may need to do if this happens to you.

Run this commmand in the terminal:

$ unset OS_SERVICE_TOKEN
$ unset OS_SERVICE_ENDPOINT

Also, check your /etc/nova/nova.conf and /etc/nova/nova-compute.conf files for any misconfigured authentication settings, which may prevent ceilometer-agent-compute from logging in.

If you continue facing issues, see if this bug affects you.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-06-15 00:40:55 -0600

Seen: 1,012 times

Last updated: Jul 07 '13