Ask Your Question
0

slow ping into gre tunnel

asked 2013-12-06 15:18:37 -0600

ronan-lanore gravatar image

hi all,

I am testing Havana openstack release with "per tenant netwok with private subnet".

I 'm using namspace + OVS + GRE.

ping is very slow between gre tunnel interfaces

ping 172.17.0.2 PING 172.17.0.2 (172.17.0.2) 56(84) bytes of data. 64 bytes from 172.17.0.2: icmp_req=1 ttl=64 time=1683 ms 64 bytes from 172.17.0.2: icmp_req=2 ttl=64 time=684 ms 64 bytes from 172.17.0.2: icmp_req=3 ttl=64 time=5111 ms 64 bytes from 172.17.0.2: icmp_req=4 ttl=64 time=4103 ms 64 bytes from 172.17.0.2: icmp_req=5 ttl=64 time=3095 ms 64 bytes from 172.17.0.2: icmp_req=6 ttl=64 time=2087 ms 64 bytes from 172.17.0.2: icmp_req=7 ttl=64 time=1079 ms 64 bytes from 172.17.0.2: icmp_req=8 ttl=64 time=71.1 ms 64 bytes from 172.17.0.2: icmp_req=9 ttl=64 time=897 ms

With iperf bandwitch is very samll on 1GB link.

oot@os-mgmt1:~# iperf -s

Server listening on TCP port 5001

TCP window size: 85.3 KByte (default)

[ 4] local 172.17.0.1 port 5001 connected with 172.17.0.2 port 35791 [ ID] Interval Transfer Bandwidth [ 4] 0.0-21.7 sec 1.25 MBytes 483 Kbits/sec

root@os-com1:~# iperf -c 172.17.0.1

Client connecting to 172.17.0.1, TCP port 5001

TCP window size: 22.9 KByte (default)

[ 3] local 172.17.0.2 port 35791 connected with 172.17.0.1 port 5001 [ ID] Interval Transfer Bandwidth [ 3] 0.0-21.7 sec 1.25 MBytes 484 Kbits/sec

My configuration:

On network node:

ifconfig eth4 eth4 Link encap:Ethernet HWaddr 00:15:17:8b:54:17
inet addr:172.17.0.1 Bcast:172.17.0.255 Mask:255.255.255.0 UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:333 errors:0 dropped:0 overruns:0 frame:0 TX packets:253 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:422348 (422.3 KB) TX bytes:19390 (19.3 KB) Interrupt:28 Memory:f7fa0000-f7fc0000

ethtool -k eth4 Features for eth4: rx-checksumming: on tx-checksumming: on tx-checksum-ipv4: off [fixed] tx-checksum-ip-generic: on tx-checksum-ipv6: off [fixed] tx-checksum-fcoe-crc: off [fixed] tx-checksum-sctp: off [fixed] scatter-gather: on tx-scatter-gather: on tx-scatter-gather-fraglist: off [fixed] tcp-segmentation-offload: on tx-tcp-segmentation: on tx-tcp-ecn-segmentation: off [fixed] tx-tcp6-segmentation: on udp-fragmentation-offload: off [fixed] generic-segmentation-offload: on generic-receive-offload: off large-receive-offload: off [fixed] rx-vlan-offload: on tx-vlan-offload: on ntuple-filters: off [fixed] receive-hashing: on highdma: on [fixed] rx-vlan-filter: on [fixed] vlan-challenged: off [fixed] tx-lockless: off [fixed] netns-local: off [fixed] tx-gso-robust: off [fixed] tx-fcoe-segmentation: off [fixed] fcoe-mtu: off [fixed] tx-nocache-copy: on loopback: off [fixed] rx-fcs: off rx-all: off

Linux os-mgmt1 3.8.0-34-generic

ovs-show : http://paste.openstack.org/show/54598/

eth4 is intel pro 1000

On compute:

ifconfig eth3 eth3 Link encap:Ethernet HWaddr 00:10:18:27:0e:61
inet addr:172.17 ...
(more)

edit retag flag offensive close merge delete

7 answers

Sort by ยป oldest newest most voted
0

answered 2013-12-20 08:39:14 -0600

ronan-lanore gravatar image

hardware problem. solved

edit flag offensive delete link more
0

answered 2013-12-06 15:24:56 -0600

ronan-lanore gravatar image

my install is:

Per-tenant routers with private networks

instead : per tenant netwok with private subnet

edit flag offensive delete link more
0

answered 2013-12-06 15:31:15 -0600

ronan-lanore gravatar image

root@os-mgmt1:~# ovs-ofctl show br-int

http://paste.openstack.org/show/54603/

root@os-com1:~# ovs-ofctl show br-int

http://paste.openstack.org/show/54604/

edit flag offensive delete link more
0

answered 2013-12-07 08:29:26 -0600

gongysh gravatar image

what version of openvswitch are u using? u can get it from ovs-vsctl show

edit flag offensive delete link more
0

answered 2013-12-07 08:50:15 -0600

ronan-lanore gravatar image

openvswith version 1.10.2

ovs-vsctl show is on

http://paste.openstack.org/show/54596/ for compute node

http://paste.openstack.org/show/54598/ for network / management node

edit flag offensive delete link more
0

answered 2013-12-12 19:55:08 -0600

I think it's non-GRE roblem.

And iperf says about it too.

As first step for resolvirn this issue I recommend try disable offloading on NIC.

edit flag offensive delete link more
0

answered 2013-12-13 08:16:15 -0600

ronan-lanore gravatar image

GRO allready off on both eth interface.

root@os-com1:~# ethtool -k eth3 generic-receive-offload: off

all parameter eth3 on compute

http://paste.openstack.org/show/54937/

root@os-mgmt1:~# ethtool -k eth4 generic-receive-offload: off

all parameter eth4 on mgmt / netwrok node

http://paste.openstack.org/show/54938/

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-12-06 15:18:37 -0600

Seen: 311 times

Last updated: Dec 20 '13