Ask Your Question
0

3 nodes are involved: controller, network gateway, compute node. New instances are not communicating at all, no ip addresses.

asked 2012-11-06 15:35:04 -0500

aryantaheri gravatar image

Seems something terribly wrong, but before starting from scratch it would be nice if someone give me some hints :)

Previously everything was working with nova-network (FlatDHCP) on the controller node.

Now 3 nodes are involved: controller, network gateway, compute node. New instances are not communicating at all, no ip addresses.

  • Each node has two interfaces, eth0: management, eth1: data

  • Namespace is not disabled

Controller: services: quantum-server, nova-* (but not nova-network), openvswitch-switch ifconfig: http://pastebin.com/8gvGAQLd nova.conf: http://pastebin.com/TzNpMR56 ovs-vsctl show: http://pastebin.com/xrD5u1hX quantum.conf: http://pastebin.com/S9YSKCZ5 ovs_quantum_plugin.ini: http://pastebin.com/KciZ4bin [LOGS] quantum-server.log: http://paste.openstack.org/show/24617/

Network Gateway: services: quantum-l3-agent, quantum-dhcp-agent, quantum-plugin-openvswitch-agent, openvswitch-switch dhcp_agent.ini: http://pastebin.com/2pWVSqqE l3_agent.ini: http://pastebin.com/jNTbQUwG ovs_quantum_plugin.ini: http://pastebin.com/r1gPrXLF ovs-vsctl show: http://pastebin.com/Wuh9r8B7 (and here we go for the strange output without any gw-xxx interface. Note: I created two networks)

This one has only two NICs, so I haven't assigned any interface for external network. It should still work? [LOGS] dhcp-agent.log: http://paste.openstack.org/show/24609/ openvswitch-agent.log: http://paste.openstack.org/show/24613/

Compute Node: services: nova-compute, nova-api-metadata, quantum-plugin-openvswitch-agent ovs-vsctl show: http://pastebin.com/qd6kfNpJ ovs_quantum_plugin.ini: http://pastebin.com/rZVwSxf2 [LOGS] openvswitch-agent.log: http://paste.openstack.org/show/24616/

edit retag flag offensive close merge delete

12 answers

Sort by ยป oldest newest most voted
0

answered 2012-11-29 18:47:35 -0500

aryantaheri gravatar image

Dan,

It was not about ICMP, or SSH. The VM didn't get an IP address, DHCP requests were sent, I don't remember how far they got, but the network gateway didn't receive them.

I may change it back and check out how far they get.

edit flag offensive delete link more
0

answered 2012-11-29 17:54:43 -0500

danwent gravatar image

changing the libvirt_vif_driver in that way basically makes it so that nova security groups are not applied. so it may have been that you could not communicate due to the fact that nova security groups were blocking the traffic.

edit flag offensive delete link more
0

answered 2012-11-29 15:38:14 -0500

aryantaheri gravatar image

Thanks Rabi Mishra, that solved my question.

edit flag offensive delete link more
0

answered 2012-11-29 15:37:55 -0500

aryantaheri gravatar image

Rabi, Thank you

It was extremely strange, changing the "libvirt_vif_driver" to "nova.virt.libvirt.vif.LibvirtOpenVswitchVirtualPortDriver" solved the problem.

--Aryan

edit flag offensive delete link more
0

answered 2012-11-22 09:46:48 -0500

Yeah I have connected the private network to a cisco 3650 switches. Not sure of commands for HP... I think ports are vlan tagged by default...

Switch(config)# interface xx

Switch(config-if)# switchport trunk encapsulation dot1q Switch(config-if)# switchport mode trunk

On Thu, Nov 22, 2012 at 3:01 PM, Aryan < question213459@answers.launchpad.net< p="">

wrote:

Question #213459 on quantum changed: https://answers.launchpad.net/quantum/+question/213459 (https://answers.launchpad.net/quantum...)

Aryan posted a new comment: Well done, I'll check it out.

Just a terminology question, by "trunk" you mean Cisco trunking, not HP trunking? So in HP term, you've tagged those ports, or just left them untouched?

Thanks Aryan


You received this question notification because you are a direct subscriber of the question.


Regards, Rabi Mishra

edit flag offensive delete link more
0

answered 2012-11-22 09:29:47 -0500

aryantaheri gravatar image

Well done, I'll check it out.

Just a terminology question, by "trunk" you mean Cisco trunking, not HP trunking? So in HP term, you've tagged those ports, or just left them untouched?

Thanks Aryan

edit flag offensive delete link more
0

answered 2012-11-22 09:14:39 -0500

I did manage to fix it.. I have used vlans 2001:4094 in my ovs plugin 'physnet:2001:4094'. However, I have not created those VLANs on the switch. My ports in the switch are tunked for all VLANs '1:4094'. Once I created a few VLANs used by my logical networks (2001 and 2003), it worked like a charm.ch

The VLAN tages you see with 'ovs-vsctl show' on the compute nodes show 1,2 etc, but they get mapped to 2001 when go beyond the soft switch.

The other thing I have done is changed my vif drivers from what has been mentioned in many installation guides (libvirt_vif_driver=nova.virt.libvirt.vif.LibvirtHybridOVSBridgeDriver) to

libvirt_vif_driver=nova.virt.libvirt.vif.LibvirtOpenVswitchVirtualPortDriver .

Hope this helps you.

Thanks, Rabi

On Thu, Nov 22, 2012 at 1:45 PM, Aryan < question213459@answers.launchpad.net< p="">

wrote:

Question #213459 on quantum changed: https://answers.launchpad.net/quantum/+question/213459 (https://answers.launchpad.net/quantum...)

Aryan posted a new comment: Rabi,

Not yet, I'll continue working on it next week. I'll update the question in case of any success.


You received this question notification because you are a direct subscriber of the question.


Regards, Rabi Mishra

edit flag offensive delete link more
0

answered 2012-11-22 08:14:30 -0500

aryantaheri gravatar image

Rabi,

Not yet, I'll continue working on it next week. I'll update the question in case of any success.

edit flag offensive delete link more
0

answered 2012-11-19 17:44:36 -0500

Hi Aryan,

Did u manage to find a solution to your issue? I am stuck with the same issue.

thanks, Rabi

edit flag offensive delete link more
0

answered 2012-11-08 16:21:07 -0500

aryantaheri gravatar image

The new configuration is almost the same as previous one. No success yet.

quantum net-list quantum router-list quantum port-list -c id -c fixed_ips -c device_owner output: http://paste.openstack.org/show/25016/

[Network Gateway]

ovs-vsctl show

http://paste.openstack.org/show/25017/

ip netns list

http://paste.openstack.org/show/25018/

ip netns exec qdhcp-e66b8a22-daff-4850-9656-282bee68819d ifconfig

http://paste.openstack.org/show/25019/

[Compute Node]

ovs-vsctl show

http://paste.openstack.org/show/25021/

If I assign the VM's IP manually (10.10.11.4), VM can retrieve the mac address for 10.10.11.2. Now when I ping there is no reply, BUT tcpdump output on both sides show something different !!!

From network gateway to the vm: http://paste.openstack.org/show/25035/ From vm to the network gateway: http://paste.openstack.org/show/25036/

One more thing which may help: I specified vlans from 200 to 250 in the config file. The vlan_allocation table confirms that. But the tag field in "ovs-vsctl show" output shows tag 1. This should not be true. (Using HP ProCurve 2910al-48g, corresponding ports are also on the DEFAULT_VLAN 1, in addition to 200-250)

Thanks.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2012-11-06 15:35:04 -0500

Seen: 218 times

Last updated: Nov 29 '12