Ask Your Question
0

3 nodes are involved: controller, network gateway, compute node. New instances are not communicating at all, no ip addresses.

asked 2012-11-06 15:35:04 -0500

aryantaheri gravatar image

Seems something terribly wrong, but before starting from scratch it would be nice if someone give me some hints :)

Previously everything was working with nova-network (FlatDHCP) on the controller node.

Now 3 nodes are involved: controller, network gateway, compute node. New instances are not communicating at all, no ip addresses.

  • Each node has two interfaces, eth0: management, eth1: data

  • Namespace is not disabled

Controller: services: quantum-server, nova-* (but not nova-network), openvswitch-switch ifconfig: http://pastebin.com/8gvGAQLd nova.conf: http://pastebin.com/TzNpMR56 ovs-vsctl show: http://pastebin.com/xrD5u1hX quantum.conf: http://pastebin.com/S9YSKCZ5 ovs_quantum_plugin.ini: http://pastebin.com/KciZ4bin [LOGS] quantum-server.log: http://paste.openstack.org/show/24617/

Network Gateway: services: quantum-l3-agent, quantum-dhcp-agent, quantum-plugin-openvswitch-agent, openvswitch-switch dhcp_agent.ini: http://pastebin.com/2pWVSqqE l3_agent.ini: http://pastebin.com/jNTbQUwG ovs_quantum_plugin.ini: http://pastebin.com/r1gPrXLF ovs-vsctl show: http://pastebin.com/Wuh9r8B7 (and here we go for the strange output without any gw-xxx interface. Note: I created two networks)

This one has only two NICs, so I haven't assigned any interface for external network. It should still work? [LOGS] dhcp-agent.log: http://paste.openstack.org/show/24609/ openvswitch-agent.log: http://paste.openstack.org/show/24613/

Compute Node: services: nova-compute, nova-api-metadata, quantum-plugin-openvswitch-agent ovs-vsctl show: http://pastebin.com/qd6kfNpJ ovs_quantum_plugin.ini: http://pastebin.com/rZVwSxf2 [LOGS] openvswitch-agent.log: http://paste.openstack.org/show/24616/

edit retag flag offensive close merge delete

12 answers

Sort by ยป oldest newest most voted
0

answered 2012-11-22 09:46:48 -0500

Yeah I have connected the private network to a cisco 3650 switches. Not sure of commands for HP... I think ports are vlan tagged by default...

Switch(config)# interface xx

Switch(config-if)# switchport trunk encapsulation dot1q Switch(config-if)# switchport mode trunk

On Thu, Nov 22, 2012 at 3:01 PM, Aryan < question213459@answers.launchpad.net< p="">

wrote:

Question #213459 on quantum changed: https://answers.launchpad.net/quantum/+question/213459 (https://answers.launchpad.net/quantum...)

Aryan posted a new comment: Well done, I'll check it out.

Just a terminology question, by "trunk" you mean Cisco trunking, not HP trunking? So in HP term, you've tagged those ports, or just left them untouched?

Thanks Aryan


You received this question notification because you are a direct subscriber of the question.


Regards, Rabi Mishra

edit flag offensive delete link more
0

answered 2012-11-29 15:37:55 -0500

aryantaheri gravatar image

Rabi, Thank you

It was extremely strange, changing the "libvirt_vif_driver" to "nova.virt.libvirt.vif.LibvirtOpenVswitchVirtualPortDriver" solved the problem.

--Aryan

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2012-11-06 15:35:04 -0500

Seen: 440 times

Last updated: Nov 29 '12