Devstack installation error on Ubuntu 64

asked 2013-06-14 13:51:16 -0600

achanda gravatar image

updated 2013-06-14 14:02:50 -0600

I am trying to install Devstack on Ubuntu 12.04 (64 bit) and crashes with this error:

2013-06-14 11:26:49 + glance --os-auth-token --os-image-url image-create --name cirros-0.3.1-x86_64-uec --public --container-format ami --disk-format ami
2013-06-14 11:26:50 usage: glance [--version] [-d] [-v] [-k] [--cert-file CERT_FILE]
2013-06-14 11:26:50               [--key-file KEY_FILE] [--os-cacert <ca-certificate-file>]
stack@abhishek-VirtualBox:~/devstack$ 2013-06-14 11:26:50               [--ca-file OS_CACERT] [--timeout TIMEOUT] [--no-ssl-compression]
2013-06-14 11:26:50               [-f] [--dry-run] [--ssl] [-H ADDRESS] [-p PORT]
2013-06-14 11:26:50               [--os-username OS_USERNAME] [-I OS_USERNAME]
2013-06-14 11:26:50               [--os-password OS_PASSWORD] [-K OS_PASSWORD]
2013-06-14 11:26:50               [--os-tenant-id OS_TENANT_ID] [--os-tenant-name OS_TENANT_NAME]
2013-06-14 11:26:50               [-T OS_TENANT_NAME] [--os-auth-url OS_AUTH_URL] [-N OS_AUTH_URL]
2013-06-14 11:26:50               [--os-region-name OS_REGION_NAME] [-R OS_REGION_NAME]
2013-06-14 11:26:50               [--os-auth-token OS_AUTH_TOKEN] [-A OS_AUTH_TOKEN]
2013-06-14 11:26:50               [--os-image-url OS_IMAGE_URL] [-U OS_IMAGE_URL]
2013-06-14 11:26:50               [--os-image-api-version OS_IMAGE_API_VERSION]
2013-06-14 11:26:50               [--os-service-type OS_SERVICE_TYPE]
2013-06-14 11:26:50               [--os-endpoint-type OS_ENDPOINT_TYPE] [-S OS_AUTH_STRATEGY]
2013-06-14 11:26:50 glance: error: argument --os-auth-token: expected one argument
2013-06-14 11:26:50 ++ failed
2013-06-14 11:26:50 ++ local r=2
2013-06-14 11:26:50 +++ jobs -p
2013-06-14 11:26:50 ++ kill
2013-06-14 11:26:50 ++ set +o xtrace
2013-06-14 11:26:50 failed: full log in /opt/stack/logs/

The log file has the same information. It also has this error for keystone:

2013-06-14 11:54:44 Configuration error: Client configured to run without a service catalog. Run the client using --os-auth-url or OS_AUTH_URL, instead of --os-endpoint or OS_SERVICE_ENDPOINT, for example.

It seems that keystone is not configured properly. That causes the OS_AUTH_TOKEN to be empty. Any idea why?

edit retag flag offensive close merge delete

3 answers

Sort by ยป oldest newest most voted

answered 2013-06-14 23:28:31 -0600

Sagar Ratnakara Nikam gravatar image

Set the no_proxy and try to run

run this command on the terminal

export no_proxy="localhost,, IP of your machine"

edit flag offensive delete link more


This worked. Thanks.

achanda gravatar imageachanda ( 2013-06-24 14:39:57 -0600 )edit

answered 2013-06-15 14:09:07 -0600


I was getting the same error, and check a bit early in the log you may found this:

Authorization Failed: An unexpected error prevented the server from fulfilling your request. [Errno 12] Cannot allocate memory (HTTP 500)

Which may give you a hint in how to fix it, I was running in an small vm machine I just increased the memory size and is working fine.

edit flag offensive delete link more

answered 2013-06-15 21:41:58 -0600

gt gravatar image

I am running to same issues -- started with the latest version I downloaded today (things were working fine with the version yesterday). I tried both proposed sol above -- inc memory and set no_proxy -- still getting same error.

Will appreciate any help.

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools


Asked: 2013-06-14 13:51:16 -0600

Seen: 4,752 times

Last updated: Jun 15 '13