Ask Your Question

changing the bind_port in proxy-server.conf

asked 2012-05-30 15:35:00 -0600

dubi-il gravatar image

I am using the current devstack (master) . If port 8080 is used by another service and I want to change the bind_port- where else should I make changes or update the new bind_port)

The reason is that if I change to anothr value (e.g. 80802 - which is not used by another service as seen by netstat) I get my system hanging when I command : swift stat

Also : what version is stable enough (if not master) if I want to use swift with a real disk object store i.e the proxy-server and the objetc -server are to be separate .

   how do I command (in loacalrc) to use that stable version after 'gitting' as follows: 
   git clone git://

   Is it just add to localrc somelines like this:

   SWIFT_BRANCH=1.4.8  (or SWIFT_BRANCH=stable/essex ?)


edit retag flag offensive close merge delete

3 answers

Sort by ยป oldest newest most voted

answered 2012-06-06 09:56:05 -0600

There is no such setting in devstack feel free to log a bug (and patch if you want) to have this added.

Swift should always be stable but to make sure you may want to pin everything to stable/essex.

edit flag offensive delete link more

answered 2012-06-06 11:04:52 -0600

dubi-il gravatar image

It turns that tomcat was using the same port as 8080 . when I chnage the port of tomcat (-> 80801) i can have the swift working ok.

So swift is rigid with its bid port . I am using the master got now (not the essex)

thx Chmouel

edit flag offensive delete link more

answered 2012-06-15 06:35:48 -0600

Swift is definitively not rigid since you can change bind_port, for devstack there is now SWIFT_DEFAULT_BIND_PORT variable if you set this up in your localrc will make swift bind to it.

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2012-05-30 15:35:00 -0600

Seen: 145 times

Last updated: Jun 15 '12