nova package install error

asked 2010-12-08 21:51:34 -0500

shinys gravatar image

Hi,

I am trying to install nova from packages through nova PPA as per https://launchpad.net/~nova-core/+archive/trunk/ (https://launchpad.net/~nova-core/+arc...) . I am unable to install nova from the recent packages. Looks like its internally installing python-nova and is developing some file conflicts. Below is what I see:

root@node15:~/openstack# dpkg -l | grep nova root@node15:~/openstack# apt-get install nova-common Reading package lists... Done Building dependency tree
Reading state information... Done The following packages were automatically installed and are no longer required: powernap avahi-utils libnss-mdns libavahi-core6 ethtool libyaml-0-2 linux-headers-2.6.32-25 libtirpc1 linux-headers-2.6.32-25-server libdaemon0 avahi-daemon python-yaml Use 'apt-get autoremove' to remove them. The following extra packages will be installed: python-nova The following NEW packages will be installed: nova-common python-nova 0 upgraded, 2 newly installed, 0 to remove and 19 not upgraded. 19 not fully installed or removed. Need to get 0B/257kB of archives. After this operation, 1,712kB of additional disk space will be used. Do you want to continue [Y/n]? Y WARNING: The following packages cannot be authenticated! python-nova nova-common Install these packages without verification [y/N]? y Selecting previously deselected package python-nova. (Reading database ... 107462 files and directories currently installed.) Unpacking python-nova (from .../python-nova_2011.1~bzr450-0ubuntu0ppa1~lucid1_all.deb) ... Unpacking nova-common (from .../nova-common_2011.1~bzr450-0ubuntu0ppa1~lucid1_all.deb) ... dpkg: error processing /var/cache/apt/archives/nova-common_2011.1~bzr450-0ubuntu0ppa1~lucid1_all.deb (--unpack): trying to overwrite '/usr/share/apport/package-hooks/source_nova.py', which is also in package python-nova 0:2011.1~bzr450-0ubuntu0ppa1~lucid1 Errors were encountered while processing: /var/cache/apt/archives/nova-common_2011.1~bzr450-0ubuntu0ppa1~lucid1_all.deb E: Sub-process /usr/bin/dpkg returned an error code (1) root@node15:~/openstack# dpkg -l | grep nova iU python-nova 2011.1~bzr450-0ubuntu0ppa1~lucid1 OpenStack Compute - Nova - Python libraries

Could you tell me what could be wrong here. I tried installing two days ago, and it was working fine then with bzr revision number 440. Is there any specific way to download nova packages for a particular bzr revision number?

Thanks Shiny

edit retag flag offensive close merge delete

1 answer

Sort by » oldest newest most voted
0

answered 2010-12-09 07:44:27 -0500

soren gravatar image

This should be resolved in the most recent version in the trunk PPA.


Soren Hansen Ubuntu Developer    http://www.ubuntu.com/ OpenStack Developer http://www.openstack.org/

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2010-12-08 21:51:34 -0500

Seen: 57 times

Last updated: Dec 09 '10