Ask Your Question
0

nova scheduler: Failed to schedule_run_instance: No valid host was found

asked 2012-04-03 13:03:35 -0600

sumit-sngpt gravatar image

The nova-scheduler during creation of an instance is throwing issue 'Failed to schedule_run_instance: No valid host was found.' This is failing at when it checks that host passes filters or not. Any idea what could be the reason and how to resolve this?

2012-04-03 12:37:20 DEBUG nova.scheduler.host_manager [req-49ea5605-9e31-4db6-955c-8acd59cf0f82 baaa0b3c108b4626a083007a72d37b01 4eabbf34471d469a91234b769b5b2af3] Host filter function <bound method="" ramfilter.host_passes="" of="" <nova.scheduler.filters.ram_filter.ramfilter="" object="" at="" 0x4217150="">> failed for mymachine-host from (pid=4567) passes_filters /home/myuser/openstack/nova/app/nova/scheduler/host_manager.py:160

2012-04-03 12:37:20 WARNING nova.scheduler.manager [req-49ea5605-9e31-4db6-955c-8acd59cf0f82 baaa0b3c108b4626a083007a72d37b01 4eabbf34471d469a91234b769b5b2af3] Failed to schedule_run_instance: No valid host was found.

2012-04-03 12:37:20 WARNING nova.scheduler.manager [req-49ea5605-9e31-4db6-955c-8acd59cf0f82 baaa0b3c108b4626a083007a72d37b01 4eabbf34471d469a91234b769b5b2af3] Setting instance c6ef30e4-ae64-46b8-aab9-700d3e68165a to ERROR state.

edit retag flag offensive close merge delete

6 answers

Sort by » oldest newest most voted
0

answered 2012-04-03 18:13:47 -0600

vishvananda gravatar image

You can tell the scheduler to overcommit ram using ram_allocation_ratio:

(FloatOpt) virtual ram to physical ram allocation ratio

ram_allocation_ratio=1.5

edit flag offensive delete link more
0

answered 2012-04-03 14:51:48 -0600

johngarbutt gravatar image

It is worth talking a look in the database service table to ensure the compute service is correctly reporting its stats.

It looks a bit like nova thinks you don't have enough RAM to launch your instance.

edit flag offensive delete link more
0

answered 2012-07-16 19:24:59 -0600

Hello, I tried adding --scheduler_default_filters=AllHostsFilter to nova.conf, reboot, no success...

Failed to schedule_run_instance: No valid host was found.

nova-manage host list host zone
2012-07-16 15:13:17 DEBUG nova.utils [req-1bcaad5f-e732-4587-80a6-761ae93d79fa None None] backend <module 'nova.db.sqlalchemy.api'="" from="" '="" usr="" lib="" python2.7="" dist-packages="" nova="" db="" sqlalchemy="" api.pyc'=""> from (pid=2895) __get_backend /usr/lib/python2.7/dist-packages/nova/utils.py:658 XEN01 nova

Ubuntu 12.04 Followed setup of stackgeek http://stackgeek.com/guides/gettingstarted.html (http://stackgeek.com/guides/gettingst...)

any developments?

edit flag offensive delete link more
0

answered 2012-04-04 00:09:09 -0600

gongysh gravatar image

I am not sure about the host status. Maybe you should first run nova-manager service-list to check if there are nova-compute smiling. And then try a tiny flavor instance.

hope it can help.

edit flag offensive delete link more
0

answered 2012-05-18 07:57:34 -0600

drolfe gravatar image

Issue fixed for me

I've had similar errors on my dev openstack deployment , adding

--scheduler_default_filters=AllHostsFilter

to nova.conf on the node running the scheduler service fixed the issue

I'm gussing the default filter didn't like the hypervisor for some reason ?

edit flag offensive delete link more
0

answered 2012-04-05 14:36:38 -0600

sumit-sngpt gravatar image

Solved this by adding following in my nova.conf then restarting openstack. No issues yet but not sure about its side affects.

scheduler_default_filters=AllHostsFilter

Let me know if there would be any issue.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2012-04-03 13:03:35 -0600

Seen: 430 times

Last updated: Jul 16 '12