Ask Your Question
0

Question on having Cinder at a separate node

asked 2013-02-20 17:16:45 -0500

kj-tanaka gravatar image

Hi,

Cinder works when I have it on the node which has Nova's management services(nova-api, nova-scheduler and such). And, now I'm working on separating Cinder services to another node, and facing some difficulty to understand how they work with Nova.

What I have on /etc/nova/nova.conf at my nova management node is this.

volume_api_class=nova.volume.cinder.API enabled_apis=ec2,osapi_compute,metadata

And what I have on /etc/cinder/api-paste.ini at cinder management node is this.

[filter:authtoken] paste.filter_factory = keystone.middleware.auth_token:filter_factory service_protocol = http service_host = "Cinder's IP" service_port = 5000 auth_host = "Keystone's IP" auth_port = 35357 auth_protocol = http admin_tenant_name = service admin_user = cinder admin_password = *****

I installed cinder-api, cinder-scheduler and cinder-volume on the separate node. And I got this error.

ERROR: Malformed request url (HTTP 400) (Request-ID: req-ddffa7d0-62cd-48cc-aca4-6e1b49f0605a)

Now I'm looking into Keystone but recreating endpoint doesn't fix it. So if any of you can kindly provide some advice or URL, I would really appreciate it.

Thanks in advance!

edit retag flag offensive close merge delete

6 answers

Sort by ยป oldest newest most voted
0

answered 2013-04-22 15:59:27 -0500

kj-tanaka gravatar image

Sorry, I accidentally reopened, but I should close this since mine has been resolved.

Koji

edit flag offensive delete link more
0

answered 2013-04-22 15:56:03 -0500

kj-tanaka gravatar image

The things which resolved my issue is to recreate Keystone's admin-user, service and endpoint. But as Karel mentioned, my service_host and service_port might be wrong. It is somehow working though.

If you could show your confg and endpoints, it would help for finding out the problem.

Koji

edit flag offensive delete link more
0

answered 2013-03-06 09:16:30 -0500

karel-striegel gravatar image

Hi I have a question regarding your configuration, you mention you have :

paste.filter_factory = keystone.middleware.auth_token:filter_factory service_protocol = http service_host = "Cinder's IP" service_port = 5000

But the service_host doesn't it reflex the keystone service instead of the cinder service ? Keystones default port is 5000 , while cinder is running on a different port.

edit flag offensive delete link more
0

answered 2013-02-20 18:29:10 -0500

kj-tanaka gravatar image

Hi I could resolve this. I deleted Cinder's endpoint, service and user. and then recreated user, service and endpoint.

Thanks!

edit flag offensive delete link more
0

answered 2013-04-12 14:06:52 -0500

kallel-ameni gravatar image

Hi, I have the same problem, Can you help me to resolve it. Thanks.

edit flag offensive delete link more
0

answered 2013-03-06 15:10:00 -0500

kj-tanaka gravatar image

Hi Karel,

The problem wasn't on the configuration, and has already been resolved. But thanks for your response!

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-02-20 17:16:45 -0500

Seen: 97 times

Last updated: Apr 22 '13