Ask Your Question
0

vm can not ping outer world with domain name

asked 2013-06-09 08:12:27 -0600

yuanyangen gravatar image

hi guys: I am new to openstack , I deploy openstack folsom on three nodes as following:

http://docs.openstack.org/folsom/basi...

I success create a instance, everything works well, in this vm ,I can ping others via ip, but when I use a domain name ,i got the following: ubuntu@inception:~$ ping www.google.com ping: unknown host www.google.com

of course, it is the dns problem, but I can't change the file /etc/resolv.conf in vm,cause it always change to the default one, the /etc/resolv.conf in the vm is like this: nameserver 50.50.10.2 domain openstacklocal search openstacklocal

in the vm ,i can ping 50.50.10.2, but in controller i can not ping to 50.50.10.2

I have the dnsmasq run on netwrok node:

network@network:~$ ps auxf | grep dns network 32695 0.0 0.0 8104 928 pts/0 S+ 15:26 0:00 _ grep --color=auto dns nobody 15651 0.0 0.0 27540 1100 ? S Jun08 0:00 dnsmasq --no-hosts --no-resolv --strict-order --bind-interfaces --interface=tapb3e23716-ae --except-interface=lo --domain=openstacklocal --pid-file=/var/lib/quantum/dhcp/47d751a7-130e-412e-911a-d52525d83e21/pid --dhcp-hostsfile=/var/lib/quantum/dhcp/47d751a7-130e-412e-911a-d52525d83e21/host --dhcp-optsfile=/var/lib/quantum/dhcp/47d751a7-130e-412e-911a-d52525d83e21/opts --dhcp-script=/usr/bin/quantum-dhcp-agent-dnsmasq-lease-update --leasefile-ro --dhcp-range=set:tag0,50.50.10.0,static,120s root 15652 0.0 0.0 27512 468 ? S Jun08 0:00 _ dnsmasq --no-hosts --no-resolv --strict-order --bind-interfaces --interface=tapb3e23716-ae --except-interface=lo --domain=openstacklocal --pid-file=/var/lib/quantum/dhcp/47d751a7-130e-412e-911a-d52525d83e21/pid --dhcp-hostsfile=/var/lib/quantum/dhcp/47d751a7-130e-412e-911a-d52525d83e21/host --dhcp-optsfile=/var/lib/quantum/dhcp/47d751a7-130e-412e-911a-d52525d83e21/opts --dhcp-script=/usr/bin/quantum-dhcp-agent-dnsmasq-lease-update --leasefile-ro --dhcp-range=set:tag0,50.50.10.0,static,120s

In both controller and network , I also add the nameserver 8.8.8.8 into the file : /etc/resolv.conf

here is my question: how could i solve this question and why this situation happens?

Thanks in advance

yuanyangen

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2013-06-17 13:53:33 -0600

patrickvinas gravatar image

Your subnet is probably configured to provide 50.50.10.2 as the nameserver to instances that get IP via DHCP. You can verify that this is the case using the quantum CLI:

quantum subnet-show <subnet id="">

will display, among other things:

... dns_nameservers 50.50.10.2 ...

You can change the nameservers in your subnet settings via command line:

quantum subnet-update <subnet-id> --dns-nameservers 8.8.8.8

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-06-09 08:12:27 -0600

Seen: 40 times

Last updated: Jun 17 '13