Unable to boot with VCDriver [closed]

asked 2013-09-09 09:34:44 -0600

namewr-hack gravatar image

When I use the VMwareVCDriver, the system report Error as follows, Any one has any idea? Thank you very much

2013-09-07 21:03:10.543 31017 ERROR suds.client [-] <soap-env:envelope xmlns:ns0="urn:vim25" xmlns:ns1="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:soap-env="http://schemas.xmlsoap.org/soap/envelope/"> <ns1:body> <ns0:retrievepropertiesex> <ns0:_this type="PropertyCollector">propertyCollector</ns0:_this> <ns0:specset> <ns0:propset> <ns0:type>ClusterComputeResource</ns0:type> <ns0:all>false</ns0:all> <ns0:pathset>name</ns0:pathset> </ns0:propset> <ns0:objectset> <ns0:obj type="Folder">group-d1</ns0:obj> <ns0:skip>false</ns0:skip> <ns0:selectset xsi:type="ns0:TraversalSpec"> <ns0:name>visitFolders</ns0:name> <ns0:type>Folder</ns0:type> <ns0:path>childEntity</ns0:path> <ns0:skip>false</ns0:skip> <ns0:selectset> <ns0:name>visitFolders</ns0:name> </ns0:selectset> <ns0:selectset xsi:type="ns0:TraversalSpec"> <ns0:name>dc_to_hf</ns0:name> <ns0:type>Datacenter</ns0:type> <ns0:path>hostFolder</ns0:path> <ns0:skip>false</ns0:skip> <ns0:selectset> <ns0:name>visitFolders</ns0:name> </ns0:selectset> </ns0:selectset> <ns0:selectset xsi:type="ns0:TraversalSpec"> <ns0:name>dc_to_vmf</ns0:name> <ns0:type>Datacenter</ns0:type> <ns0:path>vmFolder</ns0:path> <ns0:skip>false</ns0:skip> <ns0:selectset> <ns0:name>visitFolders</ns0:name> </ns0:selectset> </ns0:selectset> <ns0:selectset xsi:type="ns0:TraversalSpec"> <ns0:name>cr_to_ds</ns0:name> <ns0:type>ComputeResource</ns0:type> <ns0:path>datastore</ns0:path> <ns0:skip>false</ns0:skip> </ns0:selectset> <ns0:selectset xsi:type="ns0:TraversalSpec"> <ns0:name>cr_to_h</ns0:name> <ns0:type>ComputeResource</ns0:type> <ns0:path>host</ns0:path> <ns0:skip>false</ns0:skip> </ns0:selectset> <ns0:selectset xsi:type="ns0:TraversalSpec"> <ns0:name>cr_to_rp</ns0:name> <ns0:type>ComputeResource</ns0:type> <ns0:path>resourcePool</ns0:path> <ns0:skip>false</ns0:skip> <ns0:selectset> <ns0:name>rp_to_rp</ns0:name> </ns0:selectset> <ns0:selectset> <ns0:name>rp_to_vm</ns0:name> </ns0:selectset> </ns0:selectset> <ns0:selectset xsi:type="ns0:TraversalSpec"> <ns0:name>rp_to_rp</ns0:name> <ns0:type>ResourcePool</ns0:type> <ns0:path>resourcePool</ns0:path> <ns0:skip>false</ns0:skip> <ns0:selectset> <ns0:name>rp_to_rp</ns0:name> </ns0:selectset> <ns0:selectset> <ns0:name>rp_to_vm</ns0:name> </ns0:selectset> </ns0:selectset> <ns0:selectset xsi:type="ns0:TraversalSpec"> <ns0:name>h_to_vm</ns0:name> <ns0:type>HostSystem</ns0:type> <ns0:path>vm</ns0:path> <ns0:skip>false</ns0:skip> <ns0:selectset> <ns0:name>visitFolders</ns0:name> </ns0:selectset> </ns0:selectset> <ns0:selectset xsi:type="ns0:TraversalSpec"> <ns0:name>rp_to_vm</ns0:name> <ns0:type>ResourcePool</ns0:type> <ns0:path>vm</ns0:path> <ns0:skip>false</ns0:skip> <ns0:selectset> <ns0:name>rp_to_rp</ns0:name> </ns0:selectset> <ns0:selectset> <ns0:name>rp_to_vm</ns0:name> </ns0:selectset> </ns0:selectset> </ns0:selectset> </ns0:objectset> </ns0:specset> <ns0:options> <ns0:maxobjects>100</ns0:maxobjects> </ns0:options> </ns0:retrievepropertiesex> </ns1:body> </soap-env:envelope> 2013-09-07 21:03:10.556 31017 CRITICAL nova.virt.vmwareapi.driver [-] In vmwareapi:_call_method, got this exception: Server raised fault: '' 2013-09-07 21:03:10.556 31017 ERROR nova.all [-] Failed to load nova-compute 2013-09-07 ... (more)

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by koolhead17
close date 2014-06-05 21:07:46.340451

2 answers

Sort by ยป oldest newest most voted
0

answered 2013-09-20 00:26:48 -0600

vui gravatar image

Hi, did you resolve the startup issue? If not, please report the driver error log again. It appears that the important part of of the backtrace was truncated from the initial report. Also, did you have any cluster configured on your vCenter?

edit flag offensive delete link more
0

answered 2013-09-20 01:39:42 -0600

namewr-hack gravatar image

The problem is due to a bug inside the VCDriver. Since VCDriver is unable to handle Vcenter whose version is below 4.1, I am patching it to use different method.

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-09-09 09:34:44 -0600

Seen: 44 times

Last updated: Sep 20 '13