Ask Your Question
1

Nova is caching and using a wrong IP

asked 2013-04-10 12:53:42 -0600

Choco gravatar image

updated 2013-04-10 13:05:04 -0600

Hello Everyone,

My task ist to install OpenStack(folsom: Keystone, Glance, Nova) on one node with Xen and Ubuntu 12.04 as Dom0. After installing and configuring everything with a manual I experienced following problem.

First: I had a mistake in the endpoint table of keystone which linked to 192.168.206.130 (it was an example IP of the manual)... I changed those to localhost later but nova seems to have cached the example IP. When I run $nova --debug image-list with the right credentials for a non-administrator user on port 5000 and he responded with: REQ: curl -i http:// 192.168.206.130:8774/v2/<..........> and a 404 simply because of a wrong IP. That's why I tried to add the --no-cache-option and he responded with the right curl and the right table. It's the same with the other glance-related nova commands (e.g. nova list)

So someone can give me a solution to fix the cache or give me a hint?

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
2

answered 2013-04-24 03:44:38 -0600

unmesh-gurjar gravatar image

Choco,

AFAIK, the default behavior of Nova CLI is to disable caching. So, I think in your case, the environment variable OS_CACHE is probably set to True.

To avoid these issues, I would suggest setting the environment variable OS_CACHE to False.

edit flag offensive delete link more

Comments

Thanks a lot! I added export OS_NO_CACHE=true to my credential files.

But this can't be the long term solution for the problem!?

Choco gravatar imageChoco ( 2013-04-25 14:39:35 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2013-04-10 12:53:42 -0600

Seen: 286 times

Last updated: Apr 24 '13