error in swift-init proxy start command

asked 2012-02-06 10:15:57 -0600

lvsbisana gravatar image

I'm following the instruction in http://swift.openstack.org/howto_installmultinode.html (http://swift.openstack.org/howto_inst...)

Inside /etc/swift/proxy-server.conf

[DEFAULT] cert_file = /etc/swift/cert.crt key_file = /etc/swift/cert.key bind_port = 8080 workers = 8 user = swift

[pipeline:main] pipeline = healthcheck cache tempauth proxy-server

[app:proxy-server] use = egg:swift#proxy allow_account_management = true

[filter:tempauth] use = egg:swift#tempauth user_system_root = testpass .admin https://$PROXY_LOCAL_NET_IP:8080/v1/AUTH_system

[filter:healthcheck] use = egg:swift#healthcheck

[filter:cache] use = egg:swift#memcache memcache_servers = $PROXY_LOCAL_NET_IP:11211

The rest of the commands were running fine, until I encounter this..

enteng@cloud1:/etc/swift$ sudo swift-init proxy start [sudo] password for enteng: Starting proxy-server...(/etc/swift/proxy-server.conf) Traceback (most recent call last): File "/usr/bin/swift-proxy-server", line 22, in <module> run_wsgi(conf_file, 'proxy-server', default_port=8080, **options) File "/usr/lib/python2.7/dist-packages/swift/common/wsgi.py", line 118, in run_wsgi sock = get_socket(conf, default_port=kwargs.get('default_port', 8080)) File "/usr/lib/python2.7/dist-packages/swift/common/wsgi.py", line 84, in get_socket bind_addr) Exception: Could not bind to 0.0.0.0:8080 after trying for 30 seconds

Please help! Thanks!

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2012-02-07 08:20:36 -0600

check if the proxy server is already started, or any other process has occupied port 8080.

edit flag offensive delete link more
0

answered 2012-02-07 11:31:37 -0600

lvsbisana gravatar image

Thanks amwang, that solved my question.

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2012-02-06 10:15:57 -0600

Seen: 78 times

Last updated: Feb 07 '12