Ask Your Question
0

Proxy : No section 'auth' (prefixed by 'filter')

asked 2011-06-01 16:55:16 -0500

rclocal gravatar image

Hi,

I followed the docs and am getting the following :

Starting proxy-server...(/etc/swift/proxy-server.conf) Traceback (most recent call last): File "/usr/bin/swift-proxy-server", line 22, in <module> run_wsgi(conf_file, 'proxy-server', default_port=8080, *options) File "/usr/lib/pymodules/python2.7/swift/common/wsgi.py", line 128, in run_wsgi app = loadapp('config:%s' % conf_file, global_conf={'log_name': log_name}) File "/usr/lib/pymodules/python2.7/paste/deploy/loadwsgi.py", line 204, in loadapp return loadobj(APP, uri, name=name, *kw) File "/usr/lib/pymodules/python2.7/paste/deploy/loadwsgi.py", line 224, in loadobj global_conf=global_conf) File "/usr/lib/pymodules/python2.7/paste/deploy/loadwsgi.py", line 248, in loadcontext global_conf=global_conf) File "/usr/lib/pymodules/python2.7/paste/deploy/loadwsgi.py", line 278, in _loadconfig return loader.get_context(object_type, name, global_conf) File "/usr/lib/pymodules/python2.7/paste/deploy/loadwsgi.py", line 405, in get_context global_additions=global_additions) File "/usr/lib/pymodules/python2.7/paste/deploy/loadwsgi.py", line 503, in _pipeline_app_context for name in pipeline[:-1]] File "/usr/lib/pymodules/python2.7/paste/deploy/loadwsgi.py", line 363, in get_context object_type, name=name) File "/usr/lib/pymodules/python2.7/paste/deploy/loadwsgi.py", line 528, in find_config_section self.filename)) LookupError: No section 'auth' (prefixed by 'filter') found in config /etc/swift/proxy-server.conf

cat /etc/swift/proxy-server.conf

[DEFAULT] cert_file = /etc/swift/XXXXXXXX.crt key_file = /etc/swift/XXXXXXXXXXXX.key bind_port = 8080 workers = 8 user = swift

[pipeline:main] pipeline = healthcheck cache auth proxy-server

[app:proxy-server] use = egg:swift#proxy allow_account_management = true

[filter:swauth] user = egg:swift#swauth

Highly recommended to change this.

super_admin_key =XXXXXXXXXXX

[filter:healthcheck] use = egg:swift#healthcheck

[filter:cache] use = egg:swift#memcache memcache_servers = XXXXXXXXXX11211

edit retag flag offensive close merge delete

5 answers

Sort by ยป oldest newest most voted
0

answered 2011-06-01 17:08:54 -0500

clay-gerrard gravatar image

oh, didn't catch that first time, the entry point line in the filter:swauth section should be keyed on "use" not "user"

[filter:swauth] use = egg:swift#swauth

^ note the missing "r"

edit flag offensive delete link more
0

answered 2011-06-01 17:12:15 -0500

rclocal gravatar image

Perfrect !

Serves me right for copy pasting from the documentation.

I'm off to leave a comment on the docs !!!!!!!!

Thank you !!!!!!

edit flag offensive delete link more
0

answered 2011-06-01 17:12:27 -0500

rclocal gravatar image

Thanks clayg, that solved my question.

edit flag offensive delete link more
0

answered 2011-06-01 17:03:51 -0500

rclocal gravatar image

Nope... tried that already.. ;-p

Starting proxy-server...(/etc/swift/proxy-server.conf) Traceback (most recent call last): File "/usr/bin/swift-proxy-server", line 22, in <module> run_wsgi(conf_file, 'proxy-server', default_port=8080, *options) File "/usr/lib/pymodules/python2.7/swift/common/wsgi.py", line 128, in run_wsgi app = loadapp('config:%s' % conf_file, global_conf={'log_name': log_name}) File "/usr/lib/pymodules/python2.7/paste/deploy/loadwsgi.py", line 204, in loadapp return loadobj(APP, uri, name=name, *kw) File "/usr/lib/pymodules/python2.7/paste/deploy/loadwsgi.py", line 224, in loadobj global_conf=global_conf) File "/usr/lib/pymodules/python2.7/paste/deploy/loadwsgi.py", line 248, in loadcontext global_conf=global_conf) File "/usr/lib/pymodules/python2.7/paste/deploy/loadwsgi.py", line 278, in _loadconfig return loader.get_context(object_type, name, global_conf) File "/usr/lib/pymodules/python2.7/paste/deploy/loadwsgi.py", line 405, in get_context global_additions=global_additions) File "/usr/lib/pymodules/python2.7/paste/deploy/loadwsgi.py", line 503, in _pipeline_app_context for name in pipeline[:-1]] File "/usr/lib/pymodules/python2.7/paste/deploy/loadwsgi.py", line 413, in get_context section) File "/usr/lib/pymodules/python2.7/paste/deploy/loadwsgi.py", line 455, in _context_from_explicit "No loader given in section %r" % section) LookupError: No loader given in section 'filter:swauth'

cat proxy-server.conf

[DEFAULT] cert_file = /etc/swift/XXXXXXXXXXXXX.crt key_file = /etc/swift/XXXXXXXXXXXXXXX.key bind_port = 8080 workers = 8 user = swift

[pipeline:main] pipeline = healthcheck cache swauth proxy-server

[app:proxy-server] use = egg:swift#proxy allow_account_management = true

[filter:swauth] user = egg:swift#swauth

Highly recommended to change this.

super_admin_key =XXXXXXXXXXXXXXX

[filter:healthcheck] use = egg:swift#healthcheck

[filter:cache] use = egg:swift#memcache memcache_servers = XXXXXXXXXXXXXX:11211

edit flag offensive delete link more
0

answered 2011-06-01 17:01:31 -0500

clay-gerrard gravatar image

that error means you don't have a section titled "filter:auth" - and that seems to be because you're using "swauth"

in your pipeline:main section, change "auth" to "swauth"

[pipeline:main] pipeline = healthcheck cache swauth proxy-server

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2011-06-01 16:55:16 -0500

Seen: 432 times

Last updated: Jun 01 '11