Ask Your Question
0

Nova: Support for VMware ESXi 5.0.0 hypervisor

asked 2013-06-26 12:29:01 -0500

pragadeeswaran gravatar image

Hi,

I am trying to use VMware hypervisor ESXi 5.0.0 as a compute resource in OpenStack 2013.1.1. The driver being used is "•vmwareapi.VMwareVCDriver". The vCenter is contains a single cluster (two nodes) running ESXi version 5.0.

In the compute node, I am seeing the below error

2013-06-26 17:45:27.532 10253 AUDIT nova.compute.resource_tracker [-] Free ram (MB): 146933 2013-06-26 17:45:27.532 10253 AUDIT nova.compute.resource_tracker [-] Free disk (GB): 55808 2013-06-26 17:45:27.533 10253 AUDIT nova.compute.resource_tracker [-] Free VCPUS: 24 2013-06-26 17:45:27.533 10253 DEBUG nova.openstack.common.rpc.amqp [-] Making synchronous call on conductor ... multicall /usr/lib/python2.7/dist-packages/nova/openstack/common/rpc/amqp.py:583 2013-06-26 17:45:27.534 10253 DEBUG nova.openstack.common.rpc.amqp [-] MSG_ID is ece63342e4254910be13ee92b948ace6 multicall /usr/lib/python2.7/dist-packages/nova/openstack/common/rpc/amqp.py:586 2013-06-26 17:45:27.534 10253 DEBUG nova.openstack.common.rpc.amqp [-] UNIQUE_ID is c85fb461be22468b846368a6b8608ac2. _add_unique_id /usr/lib/python2.7/dist-packages/nova/openstack/common/rpc/amqp.py:337 2013-06-26 17:45:27.566 10253 DEBUG nova.openstack.common.rpc.amqp [-] Making synchronous call on conductor ... multicall /usr/lib/python2.7/dist-packages/nova/openstack/common/rpc/amqp.py:583 2013-06-26 17:45:27.567 10253 DEBUG nova.openstack.common.rpc.amqp [-] MSG_ID is 3f5d065d1c8a4989b4d36415d45abe8b multicall /usr/lib/python2.7/dist-packages/nova/openstack/common/rpc/amqp.py:586 2013-06-26 17:45:27.567 10253 DEBUG nova.openstack.common.rpc.amqp [-] UNIQUE_ID is 1421bebfd9744271be63dcef74551c93. _add_unique_id /usr/lib/python2.7/dist-packages/nova/openstack/common/rpc/amqp.py:337 2013-06-26 17:45:27.597 10253 CRITICAL nova [-] Remote error: DBError (DataError) invalid input syntax for integer: "5.0.0" LINE 1: ..., 7, 24, 147445, 55808, 0, 512, 0, 'VMware ESXi', '5.0.0', '... ^ 'INSERT INTO compute_nodes (created_at, updated_at, deleted_at, deleted, service_id, vcpus, memory_mb, local_gb, vcpus_used, memory_mb_used, local_gb_used, hypervisor_type, hypervisor_version, hypervisor_hostname, free_ram_mb, free_disk_gb, current_workload, running_vms, cpu_info, disk_available_least) VALUES (%(created_at)s, %(updated_at)s, %(deleted_at)s, %(deleted)s, %(service_id)s, %(vcpus)s, %(memory_mb)s, %(local_gb)s, %(vcpus_used)s, %(memory_mb_used)s, %(local_gb_used)s, %(hypervisor_type)s, %(hypervisor_version)s, %(hypervisor_hostname)s, %(free_ram_mb)s, %(free_disk_gb)s, %(current_workload)s, %(running_vms)s, %(cpu_info)s, %(disk_available_least)s) RETURNING compute_nodes.id' {'local_gb': 55808, 'vcpus_used': 0, 'deleted': 0, 'hypervisor_type': u'VMware ESXi', 'created_at': datetime.datetime(2013, 6, 26, 12, 15, 34, 804731), 'local_gb_used': 0, 'updated_at': None, 'hypervisor_hostname': u'10.100.10.42', 'memory_mb': 147445, 'current_workload': 0, 'vcpus': 24, 'free_ram_mb': 146933, 'running_vms': 0, 'free_disk_gb': 55808, 'service_id': 7, 'hypervisor_version': u'5.0.0', 'disk_available_least': None, 'deleted_at': None, 'cpu_info': u'{"model": "Intel(R) Xeon(R) CPU L5640 @ 2.27GHz", "vendor": "HP", "topology": {"cores": 12, "threads": 24, "sockets": 2}}', 'memory_mb_used': 512} [u'Traceback (most recent call last):\n', u' File "/usr/lib/python2.7/dist-packages/nova/openstack/common/rpc/amqp.py", line 430, in _process_data\n rval = self.proxy.dispatch(ctxt, version, method, *args)\n', u' File "/usr/lib/python2.7/dist-packages/nova/openstack/common/rpc/dispatcher.py", line 133, in dispatch\n return getattr(proxyobj, method)(ctxt, *kwargs)\n ... (more)

edit retag flag offensive close merge delete

3 answers

Sort by » oldest newest most voted
0

answered 2013-07-03 06:29:07 -0500

Hi,

I too facing issue in integrating OPenstack Grizzly with Vmware using Vcenter driver . (vmareapi.VMware.VCDriver) . Though I tried to use the ---vmareapi.VMwareESXdriver -- , I could not succeed in that . Always I am getting error.

Can you tell me about your configuration , ie.. It would be great if you can provide me the nova.conf fie details

Thanks, Biju

edit flag offensive delete link more
0

answered 2013-10-31 22:55:08 -0500

Can you copy your nova.conf file and paste it here. This might be a WSDL issue? Also, are you using devstack to deploy your cloud?

edit flag offensive delete link more
0

answered 2013-06-26 12:30:07 -0500

pragadeeswaran gravatar image

The backend is PostGreSQL

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-06-26 12:29:01 -0500

Seen: 92 times

Last updated: Oct 31 '13