state of compute node is XXX

asked 2011-12-01 14:27:05 -0600

bio-vishnu gravatar image

I am able to install and run all in one configuration When i add another compute node to the network

and do nova-manage service list Binary Host Zone status State Updated_at nova-compute ubunrtu nova enabled :-)
nova-scheduler ubunrtu nova enabled :-)
nova-network ubunrtu nova enabled :-)
nova-compute ubunrtu2 nova enabled XXX nova-scheduler ubunrtu2 nova enabled XXX nova-network ubunrtu2 nova enabled XXX

what that state is ? Is there any problem

edit retag flag offensive close merge delete

3 answers

Sort by ยป oldest newest most voted
0

answered 2012-07-05 07:54:47 -0600

Thanks, this solved the state problem with our third compute.

After many headaches, we noticed our error, forgeting to configure the ntp client on this compute.

Thisa answer must help a lot of people to remind the checking of dates in the infraestructure.

edit flag offensive delete link more
0

answered 2011-12-03 00:54:14 -0600

raphael-g gravatar image

This must be a time synchronization issue between ubunrtu and ubunrtu2. Here you probably have run your nova-manage command on ubunrtu. This is why all services running on ubunrtu are considered up. But since date on ubunrtu2 is not the same as the one on ubunrtu, all services running on ubunrtu2 are considered down Run command 'date' on both nodes and ensure that they are synchronized.

Each service, when launched, registers itself in database (table services). Services then send periodic heart beats (every 10 seconds by default, but you can configure the flag report_interval) in database to show that they are still alive (the report count field grows up in database) : this is for instance useful for schedulers to know which compute nodes registered in database are available. But to decide whether service B is alive, service A will compute the time interval : Current_time(based on date A) - Time_last_report(based on date B) If this delta is greater than the flags value service_down_time, node B will be considered down by A. So if you are running your services on several nodes, this requires that they are time synchronized (for instance by ntp, but a manual time adjustment will also work)

edit flag offensive delete link more
0

answered 2012-01-18 04:33:05 -0600

I had same problem. I adjusted time with ntpdate command. After that all node state changed!

Thank you for your info!

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2011-12-01 14:27:05 -0600

Seen: 242 times

Last updated: Jul 05 '12