default_swift_cluster and swauth

asked 2011-03-09 17:01:33 -0600

daniel-marzini gravatar image

Hi All, it seems that the default_swift_cluster variable in the proxy.conf is not read by the daemon.

The configuration check is done correctly but if the variable changes with something like: default_swift_cluster = local#http://10.227.89.191:8080/v1

the X-storage-url which is returned from the proxy is always with indication of the localhost. For example: X-Storage-Url: https://127.0.0.1:8080/v1/AUTH_b0e94a36-089f-4792-a831-4fd9ddc18ccc (https://127.0.0.1:8080/v1/AUTH_b0e94a...)

Is this a bug or I have made some error?

Thanking you, Regards, Daniel

edit retag flag offensive close merge delete

5 answers

Sort by ยป oldest newest most voted
0

answered 2011-03-10 08:32:24 -0600

daniel-marzini gravatar image

Thanks gholt, that solved my question.

edit flag offensive delete link more
0

answered 2011-03-10 08:31:39 -0600

daniel-marzini gravatar image

You were right with the first answer. I reboot the machine and the thing starts working. Maybe the first "swift-init proxy stop" didn't stop all the processes.

Thanks for your help.

Regards, D.

edit flag offensive delete link more
0

answered 2011-03-09 18:26:36 -0600

gholt gravatar image

default_swift_cluster indicates the setting for accounts created from that point forward (for example, you might've just stood up a new cluster you want to send new users to). But it doesn't change existing account settings. You can change existing account settings with swauth-set-account-service.

edit flag offensive delete link more
0

answered 2011-03-09 18:49:06 -0600

daniel-marzini gravatar image

Thanks for your response.

I've tried to add a new account after the change in the proxy.conf. Unfortunately nothing it still does not change the x-storage-url.

D. ------Messaggio originale------ Da: gholt Mittente:bounces@canonical.com A:daniel@marzini.net Rispondi a:question148450@answers.launchpad.net Oggetto: Re: [Question #148450]: default_swift_cluster and swauth Inviato: 9 Mar 2011 19:26

Your question #148450 on OpenStack Object Storage (swift) changed: https://answers.launchpad.net/swift/+question/148450 (https://answers.launchpad.net/swift/+...)

Status: Open => Answered

gholt proposed the following answer: default_swift_cluster indicates the setting for accounts created from that point forward (for example, you might've just stood up a new cluster you want to send new users to). But it doesn't change existing account settings. You can change existing account settings with swauth- set-account-service.


If this answers your question, please go to the following page to let us know that it is solved: https://answers.launchpad.net/swift/+question/148450/+confirm?answer_id=0 (https://answers.launchpad.net/swift/+...)

If you still need help, you can reply to this email or go to the following page to enter your feedback: https://answers.launchpad.net/swift/+question/148450 (https://answers.launchpad.net/swift/+...)

You received this question notification because you are a direct subscriber of the question.

edit flag offensive delete link more
0

answered 2011-03-09 20:15:33 -0600

gholt gravatar image

Did you restart or reload the proxy after you changed the configuration? Or perhaps did you typo the section or variable name? If the value is determined as missing, it will default to local#http://127.0.0.1:8080/v1 Can you post your proxy-server.conf?

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2011-03-09 17:01:33 -0600

Seen: 87 times

Last updated: Mar 10 '11