Ask Your Question
0

Savanna with Quantum Network

asked 2013-07-21 07:34:11 -0500

Hi,

I installed Savanna including the dashboard. I am able to create everything, like node group templates, cluster templates etc. But when i try to launch the cluster, i get an error. Later from few searches i found that Savanna is not ready to fully support Neutron/Quantum and only support Nova-Network [Pls correct me if i am wrong].

Is there any workaround, that can make Savanna work on a Quantum Network. I am getting the following error in the savanna API Log.

2013-07-20 19:53:26.218 18342 WARNING savanna.service.instances [-] Can't start cluster 'test' (reason: unexpected type <type 'nonetype'=""> for addr arg) Traceback (most recent call last): File "/usr/local/savanna/savanna-venv/local/lib/python2.7/site-packages/eventlet/hubs/hub.py", line 346, in fire_timers timer() File "/usr/local/savanna/savanna-venv/local/lib/python2.7/site-packages/eventlet/hubs/timer.py", line 56, in __call__ cb(args, *kw) File "/usr/local/savanna/savanna-venv/local/lib/python2.7/site-packages/eventlet/greenthread.py", line 194, in main result = function(args, *kwargs) File "/usr/local/savanna/savanna-venv/local/lib/python2.7/site-packages/savanna/context.py", line 127, in wrapper func(args, *kwargs) File "/usr/local/savanna/savanna-venv/local/lib/python2.7/site-packages/savanna/service/api.py", line 110, in _provision_cluster i.create_cluster(cluster) File "/usr/local/savanna/savanna-venv/local/lib/python2.7/site-packages/savanna/service/instances.py", line 48, in create_cluster _rollback_cluster_creation(cluster, ex) File "/usr/lib/python2.7/contextlib.py", line 24, in __exit__ self.gen.next() File "/usr/local/savanna/savanna-venv/local/lib/python2.7/site-packages/savanna/service/instances.py", line 36, in create_cluster _await_instances(cluster) File "/usr/local/savanna/savanna-venv/local/lib/python2.7/site-packages/savanna/service/instances.py", line 183, in _await_instances if not _check_if_up(instance): File "/usr/local/savanna/savanna-venv/local/lib/python2.7/site-packages/savanna/service/instances.py", line 203, in _check_if_up if not networks.init_instances_ips(instance, server): File "/usr/local/savanna/savanna-venv/local/lib/python2.7/site-packages/savanna/service/networks.py", line 55, in init_instances_ips network = netaddr.IPNetwork(nova_network.cidr) File "/usr/local/savanna/savanna-venv/local/lib/python2.7/site-packages/netaddr/ip/__init__.py", line 907, in __init__ implicit_prefix, flags) File "/usr/local/savanna/savanna-venv/local/lib/python2.7/site-packages/netaddr/ip/__init__.py", line 802, in parse_ip_network raise TypeError('unexpected type %s for addr arg' % type(addr)) TypeError: unexpected type <type 'nonetype'=""> for addr arg (18342) accepted ('127.0.0.1', 42740)

Thanks in advance.

edit retag flag offensive close merge delete

16 answers

Sort by ยป oldest newest most voted
0

answered 2013-07-31 12:15:07 -0500

This is my modifications to the actual code. Didnt find a method to share file here, so pasting the code.

http://paste.openstack.org/show/42740/

Regards

edit flag offensive delete link more
0

answered 2013-08-09 08:20:37 -0500

jfzhang1984 gravatar image

I also have this problem, and modify the source code in service/networks.py and instances.py

edit flag offensive delete link more
0

answered 2013-08-29 19:31:46 -0500

I have the same problem, and updated the network.py code per the comments above. However, when I launch the cluster it sits in the 'waiting' state indefinitely. The debug output keeps looping throught the servers it created for the clustuer. The following information is what keeps getting displayed. Looks like the management_ip is None, and not sure if that is the root of my problem.

2013-08-29 11:00:58.793 14371 WARNING savanna.service.networks [-] This is the server networks : {u'External': [u'10.10.10.95']} 2013-08-29 11:00:58.793 14371 WARNING savanna.service.networks [-] Length of IP List : 1 2013-08-29 11:00:58.794 14371 WARNING savanna.service.networks [-] This is the network_label External 2013-08-29 11:00:58.794 14371 WARNING savanna.service.networks [-] This is the management IP :None 2013-08-29 11:00:58.794 14371 WARNING savanna.service.networks [-] This is the IP :10.10.10.95 2013-08-29 11:00:59.877 14371 WARNING savanna.service.networks [-] This is the intance : <savanna.db.models.instance[object at="" 383a4="" d0]="" {created="datetime.datetime(2013," 8,="" 29,="" 17,="" 38,="" 11,="" 76763),="" updated="datetime.datetime(2013," 8,="" 29,="" 17,="" 38,="" 11,="" 76771),="" extra="Non" e,="" node_group_id="u'8841ab56-23a7-46d6-a65c-95222cb9102c'," instance_id="u'c29b8ced-6382-4f89-8bf9-96a662275a37'," instance_name="u'TestCluster-NameNode_JobTacker_Medium-001'," internal_ip="u'10.10.10.98'," management_ip="None," volumes="[]}&gt;" 2013-08-29="" 11:00:59.877="" 14371="" warning="" savanna.service.networks="" [-]="" this="" is="" the="" server="" :="" <server:="" testcluster-namenode_jobtack="" er_medium-001="">

edit flag offensive delete link more
0

answered 2013-08-29 19:43:54 -0500

SergeyLukjanov gravatar image

Work on basic support of neutron has been started:

https://review.openstack.org/#/c/44001/ https://review.openstack.org/#/c/44054/

edit flag offensive delete link more
0

answered 2013-08-29 19:50:48 -0500

Dear Bill,

The changes will work only with some conditions.

  1. Each VM in cluster should have only 1 Network Interface attached and a floating IP.
  2. There should be exactly 1 floating IP for all the instances spun up in the cluster.

Based on your description the management IP is null, which means you didnt apply floating IP to instances. Try to add floating IP for each node, and monitor the logs. You can see the floating IP coming up as the management IP and after that the cluster configuration will start and succeed.

edit flag offensive delete link more
0

answered 2013-08-29 22:28:08 -0500

I was able to edit the network.py file to allow the internal IPs to be used. This corrected my issue. Change was to:

... cluster_node_opts = [ cfg.BoolOpt('use_floating_ips', + default=False, # True - default setting; uses floating IP. False allows for external/internal IPs to be used instead ...

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-07-21 07:34:11 -0500

Seen: 141 times

Last updated: Aug 29 '13