Ask Your Question
0

Error: Unable to locate package neutron-server E: Unable to locate package python-neutronclient

asked 2013-09-25 12:40:12 -0500

sachin-p-puranik gravatar image

Hi,

Am trying to set up Openstack Neutron only on Ubunto 12.04 which is hosted in VirtualBox. Plan is to make use of the Neutron Module via the CLI tool and understand the same.

Am following the steps given in http://docs.openstack.org/trunk/openstack-network/admin/content/install_ubuntu.html (http://docs.openstack.org/trunk/opens...)

Added the deb http://ubuntu-cloud.archive.canonical.com/ubuntu (http://ubuntu-cloud.archive.canonical...) precise-updates/grizzly main in /etc/apt/source.list then executed following commands and pasted below is the list of the logs of execution till i hit the error for the command sudo apt-get install neutron-server python-neutronclient.

Kindly help me how to resolve this or any other alternative to Install Neutron. Thanks in Advance.

Commands executed: $sudo apt-get install ubuntu-cloud-keyring $sudo apt-get update $sudo apt-get upgrade $sudo apt-get install neutron-server python-neutronclient <-------------ERROR

edit retag flag offensive close merge delete

6 answers

Sort by ยป oldest newest most voted
0

answered 2013-09-27 13:28:39 -0500

sachin-p-puranik gravatar image

Thanks ZhiQiang Fan, that solved my question.

edit flag offensive delete link more
0

answered 2013-09-26 14:17:29 -0500

aji-zqfan gravatar image

apt-get upgrade should run after apt-get update

in my notebook (which doesn't install quantum from ppa before), i add the grizzly ppa and update and run

apt-get install quantum-server python-quantumclient

everything is fine, no error is printed

it seems it is caused by wrong state (or wrong config) of apt, not caused by quantum, so i think you'd better search and fix it by yourself

after google the error you reported, i find this: http://ubuntuforums.org/showthread.php?t=1905494 (http://ubuntuforums.org/showthread.ph...) http://askubuntu.com/questions/311842/how-do-i-fix-apt-errors-w-failed-to-fetch-hash-sum-mismatch (http://askubuntu.com/questions/311842...) which recommends affected people to rm (you can backup this dir instead of rm it directly) /var/lib/apt/lists/partial/* (not the partial dir itself), and run apt-get update

ps: in my apt sources.list, precise-security part (this is not set manually , not related the quantum ppa) is : deb http://mirrors.163.com/ubuntu/ precise-security main restricted deb-src http://mirrors.163.com/ubuntu/ precise-security restricted main multiverse universe #Added by software-properties deb http://mirrors.163.com/ubuntu/ precise-security universe deb http://mirrors.163.com/ubuntu/ precise-security multiverse

since i'm in china, the host domain name may different from yours, but the rest part should be same, please check your config file

edit flag offensive delete link more
0

answered 2013-09-27 13:28:22 -0500

sachin-p-puranik gravatar image

Yes Some issue with OS i happ to reinstall and its working fine. Thanks Again

edit flag offensive delete link more
0

answered 2013-09-25 14:49:23 -0500

aji-zqfan gravatar image

sorry the doc is broken

if you want to install grizzly release, please change

apt-get install neutron-server python-neutronclient --> to

apt-get install quantum-server python-quantumclient

or if you want to install havana release, please add (or change the ppa) to /etc/apt/sources.list (note typo: not source.list) deb http://ubuntu-cloud.archive.canonical.com/ubuntu (http://ubuntu-cloud.archive.canonical...) precise-updates/havana main then you can install neutron-server and python-neutronclient

the other part are same, it is because this project has changed its name, sorry for this trouble.

edit flag offensive delete link more
0

answered 2013-09-25 15:08:58 -0500

aji-zqfan gravatar image

here is the grizzly guide: http://docs.openstack.org/grizzly/openstack-network/admin/content/install_ubuntu.html (http://docs.openstack.org/grizzly/ope...)

edit flag offensive delete link more
0

answered 2013-09-26 12:46:35 -0500

sachin-p-puranik gravatar image

Thank You for the reply. I followed the approach present in the above mentioned Grizzly guide and now facing a different issue while running the "python-quantumclient" install command. I get an error saying "the requested package has been moved out or not yet created" I have uploaded this "deb http://ubuntu-cloud.archive.canonical.com/ubuntu (http://ubuntu-cloud.archive.canonical...) precise-updates/grizzly main" in sources.list file.

Appreciate the help in letting me know what am i doing wrong.

First: I get the following 404 error when i run the apt-get upgrade command. .... .... ..... Err http://in.archive.ubuntu.com precise/restricted Sources
404 Not Found [IP: 91.189.92.200 80] Fetched 1,671 kB in 42s (39.3 kB/s)
W: Failed to fetch gzip:/var/lib/apt/lists/partial/in.archive.ubuntu.com_ubuntu_dists_precise_main_source_Sources Hash Sum mismatch

W: Failed to fetch http://in.archive.ubuntu.com/ubuntu/dists/precise/restricted/source/Sources (http://in.archive.ubuntu.com/ubuntu/d...) 404 Not Found [IP: 91.189.92.200 80]

W: Failed to fetch gzip:/var/lib/apt/lists/partial/in.archive.ubuntu.com_ubuntu_dists_precise_universe_source_Sources Hash Sum mismatch

W: Failed to fetch gzip:/var/lib/apt/lists/partial/in.archive.ubuntu.com_ubuntu_dists_precise_restricted_binary-i386_Packages Hash Sum mismatch

W: Failed to fetch gzip:/var/lib/apt/lists/partial/in.archive.ubuntu.com_ubuntu_dists_precise_universe_binary-i386_Packages Hash Sum mismatch

W: Failed to fetch gzip:/var/lib/apt/lists/partial/in.archive.ubuntu.com_ubuntu_dists_precise_multiverse_binary-i386_Packages Hash Sum mismatch

W: Failed to fetch http://security.ubuntu.com/ubuntu/dists/precise-security/restricted/source/Sources (http://security.ubuntu.com/ubuntu/dis...) 404 Not Found [IP: 91.189.91.14 80]

W: Failed to fetch http://security.ubuntu.com/ubuntu/dists/precise-security/multiverse/source/Sources (http://security.ubuntu.com/ubuntu/dis...) 404 Not Found [IP: 91.189.91.14 80]

E: Some index files failed to download. They have been ignored, or old ones used instead.

And then this..

apt-get install quantum-server python-quantumclient Reading package lists... Done Building dependency tree
Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:

The following packages have unmet dependencies: quantum-server : Depends: quantum-common (= 1:2013.1.2-0ubuntu1~cloud0) but it is not going to be installed Recommends: quantum-plugin-openvswitch but it is not going to be installed E: Unable to correct problems, you have held broken packages.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-09-25 12:40:12 -0500

Seen: 1,158 times

Last updated: Sep 27 '13