Ask Your Question
0

Swift installation on Ubuntu

asked 2013-04-17 10:06:19 -0600

chabani-mohamed-hadi gravatar image

Hello,

I'm working on the installation of OpenStack Object Storage (Swift) on my company's server, however i found lot of problems to achieve the installation, (I just knew openstack a month ago), so i'm wondering if some one has already try it and can help me to better understand it, i tried a lot of tutorials in openstack docs, and extern docs but i got nothing concret, please if some can give me the tutorial he followed to install Swift, it will be really great, or an mail or skype adress so we can get in touch just to understand really what should i have or do !

Thank you very much

edit retag flag offensive close merge delete

14 answers

Sort by ยป oldest newest most voted
0

answered 2013-04-30 16:20:19 -0600

clay-gerrard gravatar image

The swift logs will have the answer - /var/log/syslog or /var/log/swift

But in my experience when tempauth responds with a token that can't be used to authenticate - it's normally because memcache isn't running or is misconfigured.

Maybe check if memcache is listening on 11211, if you can confirm it is check the logs, and post your proxy-conf

GL,

-Clay

edit flag offensive delete link more
0

answered 2013-05-02 09:43:05 -0600

chabani-mohamed-hadi gravatar image

Thank you clayg for your play, i return back to the work today

My memcache was running normaly on 11211, and in the log file there wasn't anything weird, my proxy-conf is the same at the installation guide on http://docs.openstack.org/developer/swift/development_saio.html (http://docs.openstack.org/developer/s...)

So now after rebooting, i re ask for token identifiers, and i miracously i get :

Account: AUTH_admin Containers: 0 Objects: 0 Bytes: 0 Accept-Ranges: bytes X-Timestamp: 1367486364.78069 Content-Type: text/plain; charset=utf-8 root@localhost:/home# export ADMINPASS=admin

so what do you think ?? have i finished the installation and i must pass to the swift client installation now ? It's not so clear till now,.

Thank you

edit flag offensive delete link more
0

answered 2013-05-02 09:44:11 -0600

chabani-mohamed-hadi gravatar image

Thank you clayg for your answer, i return back to the work today

My memcache was running normaly on 11211, and in the log file there wasn't anything weird, my proxy-conf is the same at the installation guide on http://docs.openstack.org/developer/swift/development_saio.html (http://docs.openstack.org/developer/s...)

So now after rebooting, i re ask for token identifiers, and i miracously i get :

Account: AUTH_admin Containers: 0 Objects: 0 Bytes: 0 Accept-Ranges: bytes X-Timestamp: 1367486364.78069 Content-Type: text/plain; charset=utf-8 root@localhost:/home# export ADMINPASS=admin

so what do you think ?? have i finished the installation and i must pass to the swift client installation now ? It's not so clear till now,.

Thank you

edit flag offensive delete link more
0

answered 2013-05-02 15:06:13 -0600

chabani-mohamed-hadi gravatar image

One more thing ! i'm trying to install Swfit Client now and when i do : $ swift -A http://127.0.0.1:8080/v1.0 -U admin:admin -K $ADMINPASS upload myfiles test.jpg ---> i get :

Error trying to create container 'myfiles': 412 Precondition Failed Auth GET failed: http://127.0.0.1:8080/v1.0 412 Precondition Failed

Any idea about that ?

Ps : i follow this tutorial : http://docs.openstack.org/folsom/openstack-object-storage/admin/content/verify-swift-installation.html (http://docs.openstack.org/folsom/open...) ---> step : 5, the previous steps sems to e ok.

Thank you

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-04-17 10:06:19 -0600

Seen: 284 times

Last updated: May 02 '13