Ask Your Question
0

proxy-server won't start

asked 2012-01-31 15:28:04 -0500

amarcionek gravatar image

I'm trying a SAIO installation on Ubuntu Server 10.4. When running startmain, I get the following exception in python. I checked my .conf file and its identical with the exception of the user name of course. There is nothing in syslog or in the proxy specific log file at all.

Traceback (most recent call last): File "usr/local/bin/swift-proxy-server", line 7, in <module> execfile(__file__) File "/home/amarcionek/swift/bin/swift-proxy-server", line 22, in <module> run_wsgi(conf_file, 'proxy-server', default_port-8080, **options)

I'm omitting a bunch of lines here, but the last few seem interesting to me.

File "/usr/lib/python2.6/dist-packages/pkg_resources.py", line 546, in resolve raise DistributionNotFound(req) pkg_resources.DistributionNotFound: swifth

Anyone know what is wrong?

Thanks!

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2012-01-31 15:39:46 -0500

cthier gravatar image

My first guess is that you have swifth instead of swift in your proxy config file

edit flag offensive delete link more
0

answered 2012-01-31 15:42:51 -0500

amarcionek gravatar image

OK, I'm an idiot. I thought I looked for that string, but clearly my brain was seeing everything fuzzy in the console window. Thanks Chuck!

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2012-01-31 15:28:04 -0500

Seen: 75 times

Last updated: Jan 31 '12